Bug #12593 CREATE TABLE with some single-letter table names fails
Submitted: 16 Aug 2005 2:03 Modified: 16 Aug 2005 2:19
Reporter: Arjen Lentz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.11-beta OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[16 Aug 2005 2:03] Arjen Lentz
Description:
CREATE TABLE a (i int)
fails on Windows XP with 
  Can't find file: '.\test\c.frm' (errno: 13)
(13 = access denied)
It with InnoDB as well as ENGINE=MyISAM.

It fails when the tablename is a or c, but works with tablename b, d or e.

MySQL Server is running as the system account, so I presume it can't be a file access issue. Also, creating a table with other names works just fine.

How to repeat:
CREATE TABLE a (i int)
(on Windows XP with MySQL 5.0.11-beta)
[16 Aug 2005 2:05] Arjen Lentz
I also just tried to manually create a file named a.frm in the datadir/test directory, and that works just fine.
[16 Aug 2005 2:19] Jim Winstead
Duplicate of Bug #12325.