Bug #12563 Cannot assign privileges to new users
Submitted: 13 Aug 2005 2:31 Modified: 13 Aug 2005 11:16
Reporter: Roger Collis Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.1.0 rc OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[13 Aug 2005 2:31] Roger Collis
Description:
When attempting to apply privileges to a new user other than root, when "applying changes" the system returns an error message:

 "MySQL Administrator exception. Error while storing user info. The user might have been deleted. Please refresh user list."

Having refreshed user list, the system returns to the way it was. I cannot assign privileges to another user.

How to repeat:
Go to User Administration, appoint a new user, then try to assign global privileges to this new user.
[13 Aug 2005 11:16] Aleksey Kishkin
duplicate of http://bugs.mysql.com/bug.php?id=12306
[19 Nov 2009 19:02] Jack Johnson
I cannot believe this trivial functionality is still broken!!

Windows Vista, 64-bit

MySQL Administrator 1.2.17 (downloaded 10 minutes ago from main downloads page, 3 mirrors, supposed to be updated 2+ years ago)

Try to change schema privs for a user, upon save, get message:
"Error while storing the user information.  The user might have been deleted.  Please refresh the user list."

ridiculous!!!