Bug #12393 MyODBC newer vision than 3.51.06 doesn't work with ODBC API function SQLDriverC
Submitted: 5 Aug 2005 5:16 Modified: 9 Dec 2005 19:21
Reporter: XiaoYan Wang Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:Connector/ODBC 3.51.12 OS:Microsoft Windows (windowsXP)
Assigned to: Bugs System

[5 Aug 2005 5:16] XiaoYan Wang
Description:
When calling ODBC API function SQLDriverConnect to establish a connection with MySQL(version 4.1.7), using MyODBC version 3.51.06, connection will be successful.
However, when upgraded to vision 3.51.11 or 3.51.12, connection will fail, and the error message is:
"[MySQL][ODBC 3.51 Driver]Could not find driver {MySQL ODBC 3.51 Driver} in system information."

How to repeat:
When calling ODBC API function SQLDriverConnect to establish a connection with MySQL(version 4.1.7), using MyODBC version 3.51.11 or 3.51.12, connection will fail, and the error message is:
"[MySQL][ODBC 3.51 Driver]Could not find driver {MySQL ODBC 3.51 Driver} in system information."
[5 Aug 2005 5:56] XiaoYan Wang
The version of MyODBC is 3.51.11-1 and 3.51.11-2,not 3.51.11 and 3.51.12.
I'm sorry for my mistake.
[5 Aug 2005 7:28] Vasily Kishkin
Sorry....I was not able to reproduce the bug. My test case can connect to server without problem and I use MyODBC 3.51.11-1.
Could you please write a simple test case ?
[10 Aug 2005 1:39] XiaoYan Wang
This is a .net C#  windows application

Attachment: MyODBC.rar (application/octet-stream, text), 9.63 KiB.

[10 Aug 2005 1:43] XiaoYan Wang
Vasily Kishkin :Thanks for your reply.
If you want to get more information about my test case please
see MSDN - ODBC Programmer's Reference .
[11 Aug 2005 8:39] Vasily Kishkin
Thanks for test case. I've got the error message. I verified connection string. It seems right.
[14 Aug 2005 14:13] Jerome Kaidor
I get this exact same message with Microsoft Access 97 running on Windows 2000SP4.  It happens when I try to export a table to MySQL on my linux box,
even though the ODBC installation seems OK via the "test" button in Administration Tools|Data Sources|User DSN.  The version of MyODBC is 3.51.11.00, as reported on the "ODBC Drivers that are installed on your system"
screen.
[24 Oct 2005 3:06] Peter Harvey
Testing with latest c/odbc and one sees that the command-line tool myodbc3m works fine with SQLDriverConnect but test provided by Wang does show the specified problem with same connect used from within test case provided. Some investigation required.
[24 Oct 2005 3:11] Peter Harvey
Sergey, this should be fairly straight forward to resolve - the main problem may be getting the debug output going again. I spent some time cleaning up the debug code but some small work still required.
[26 Oct 2005 14:43] Sergey Vlasenko
The problem exists due to enclosing of driver name into {}. SQLGetPrivateProfile*() will work only with unenclosed names.
[14 Nov 2005 18:12] mattias waldau
I get the same error message:

+	System.SystemException	{"ERROR [HYT00] [MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on 'localhost' (10048)"}	System.SystemException

I have simple loop that makes 1000 reads/updates. The error occurs after a while and not at the same place when I make the system go faster, i.e. change

innodb_flush_log_at_trx_commit

from 0 to 1 or 2.

I tried MyODBC 3.51.10 3.51.12. I have tried database version 4.1.9 and 5.0.15 and always get the same problem.

The same program runs very will with ODBC with SqlServer. The rest of the program also runs well with MySQL, it is just this stress test that seems to overload the ODBC-driver.

The only special thing about my database is that each row has mediumblob field.

The program is written in ASP.NET 1.1, C#, Windows XP, VS 2003.

I tried with the Alpha 5.0 ODBC-driver but I got another error.
[15 Nov 2005 6:53] Peter Harvey
I took a look at the code dealing with parsing connection string with {} and it seems to be a good solution. This fix will be included in c/odbc 3.51.13.
[24 Nov 2005 17:10] Sergey Vlasenko
Fix is available in 3.51.13.
[9 Dec 2005 19:21] Paul Dubois
Noted in 3.51.13 changelog.
[2 Feb 2006 15:42] Marcin Lizer
where is 3.51.13 fix ???

I am waiting for it since november '05 !!!!

[24 Nov 2005 18:10] Sergey Vlasenko 
Fix is available in 3.51.13.

[9 Dec 2005 20:21] Paul DuBois 
Noted in 3.51.13 changelog.

it's noted in the change log, but the fix doesn't exist ...

I need myodbc.dll that works fine with msjet40.dll ver. 4.00.9025 !!!! 

release that fix please
[24 Feb 2006 11:14] Juan Areste
I found the version myodbc 3.51.13 in 
ftp://ftp.mysql.com/pub/mysql/hidden/connectors/odbc/
[15 Dec 2006 11:25] Michael Rossel
Where is the Fix, its not available with the above mentioned link. This would solve my problem, but the version 3.51.12 seems to be the last on.