Bug #12386 MSACCESS 2003 CRASH - MyODBC
Submitted: 4 Aug 2005 14:45 Modified: 28 May 2013 13:09
Reporter: Samuel Schouppe Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:4.1.13-nt // ODBC 3.51 OS:Microsoft Windows (WINDOWS 2000)
Assigned to: CPU Architecture:Any

[4 Aug 2005 14:45] Samuel Schouppe
Description:
When try to use to connect with MS ACCESS 2003 through my ODBC. MSACCESS crashes and asks to send a bug report to Microsoft. 

I have this on two different systems.

How to repeat:
MSACCESS 2003 -> Link table -> choose DSN -> Crash
[4 Aug 2005 15:00] Samuel Schouppe
Last lines from odbc.log. I cannot find myodbc.log ...   even in debug , trace to myodbc.log is enabled.

MSACCESS        7c8-6f0	EXIT  SQLGetInfoW  with return code 0 (SQL_SUCCESS)
		HDBC                0C4A15E8
		UWORD                       24 <SQL_CURSOR_ROLLBACK_BEHAVIOR>
		PTR                 0x0012BFAA (2)
		SWORD                        2 
		SWORD *             0x0012BF7C (2)

MSACCESS        7c8-6f0	ENTER SQLGetInfoW 
		HDBC                0C4A15E8
		UWORD                       29 <SQL_IDENTIFIER_QUOTE_CHAR>
		PTR                 0x0012BF94 
		SWORD                       20 
		SWORD *             0x0012BFBC

MSACCESS        7c8-6f0	EXIT  SQLGetInfoW  with return code 0 (SQL_SUCCESS)
		HDBC                0C4A15E8
		UWORD                       29 <SQL_IDENTIFIER_QUOTE_CHAR>
		PTR                 0x0012BF94 [       2] "`"
		SWORD                       20 
		SWORD *             0x0012BFBC (2)

MSACCESS        7c8-6f0	EXIT  SQLGetInfoW  with return code 0 (SQL_SUCCESS)
		HDBC                0C4A15E8
		UWORD                       24 <SQL_CURSOR_ROLLBACK_BEHAVIOR>
		PTR                 0x0012BFAA (2)
		SWORD                        2 
		SWORD *             0x0012BF7C (2)

MSACCESS        7c8-6f0	ENTER SQLGetInfoW 
		HDBC                0C4A15E8
		UWORD                       29 <SQL_IDENTIFIER_QUOTE_CHAR>
		PTR                 0x0012BF94 
		SWORD                       20 
		SWORD *             0x0012BFBC

MSACCESS        7c8-6f0	EXIT  SQLGetInfoW  with return code 0 (SQL_SUCCESS)
		HDBC                0C4A15E8
		UWORD                       29 <SQL_IDENTIFIER_QUOTE_CHAR>
		PTR                 0x0012BF94 [       2] "`"
		SWORD                       20 
		SWORD *             0x0012BFBC (2)
[4 Aug 2005 15:01] Samuel Schouppe
odbc log file

Attachment: SQL.LOG (application/octet-stream, text), 23.61 KiB.

[4 Aug 2005 15:08] Samuel Schouppe
When I try to connect with MS EXCEL and myodbc everything works fine ......
[4 Aug 2005 15:45] Samuel Schouppe
I changed to version msjet40.dll  4.0.8618.0 and everything works fine. Msjet40.Dll was the latest version but i did not write down version number .....
[5 Aug 2005 7:24] Vasily Kishkin
Could you please help me to find the latest version of msjet40.dll. What is URL ?
[5 Aug 2005 7:40] Samuel Schouppe
http://support.microsoft.com/default.aspx?scid=kb;nl;239114 -> Dutch

http://support.microsoft.com/default.aspx?scid=kb;en-us;239114  -> English

This was the version I had -> 4.0.8618.0 Security Bulletin MS04-014 

Hope you can reproduce error ...
[5 Aug 2005 7:45] Samuel Schouppe
sorry the problem version was 

4.0.9025.0 Update Rollup 1 for Windows 2000 SP4
[11 Aug 2005 9:05] Vasily Kishkin
Thanks for URL. I was not able to reproduce the bug on Windows 2003 with new 
msjet40.dll. Probably something wrong in Update Rollup 1 for Windows 2000 SP4.  
I'm going to verify your bug on Windows 2000 SP4 with update. The bug looks like on http://bugs.mysql.com/bug.php?id=11863.
[16 Aug 2005 11:11] Kevin Daley
I get this problem on three different 2003 Servers, using Office Access 2003. I have installed the latest Jet 4 SP8 update and it still occurs every time. No problem from XP machines. The error message is useless which suggests this is a new bug, not the one referred to in the articles above. I'll post more gen as I find it.
[19 Aug 2005 8:33] Vasily Kishkin
Maybe do you use old version of myodbc ? Could you please say me time of creation of myodbc3.dll ?  You can find it in <Windows>\system32\.
[8 Sep 2005 0:25] Kevin Daley
The version i am using is fresh from mysql.com
myodbc3.dll 11/2/2005 00:05
[8 Sep 2005 0:45] Kevin Daley
Just found Bug #9932 which has more info on this problem.
[19 Sep 2005 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[19 Oct 2005 1:49] Peter Harvey
It would help if people were using the just completed 3.51.12 release to do the trace. It can be found at; ftp://ftp.mysql.com/pub/mysql/hidden/connectors/odbc and should be published to the regular download area soon.
[19 Oct 2005 1:52] Peter Harvey
It would help to have a trace from a working scenario so it can be compared to the failed.
[28 May 2013 13:09] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.