Bug #12373 MySQL 5 server fails to start on Fedora Core 4
Submitted: 4 Aug 2005 11:45 Modified: 19 Aug 2005 13:37
Reporter: Dimitris Andrikopoulos Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Server Severity:S1 (Critical)
Version:MySQL 5.0.10 OS:Linux (Fedora Core 4)
Assigned to: CPU Architecture:Any

[4 Aug 2005 11:45] Dimitris Andrikopoulos
I used the "glibc 2.3" versions of the MySQL 5 RPM distribution on a Fedora Core 4 system. The "MySQL-server-5.0.10-0.glibc23.i386.rpm" RPM installed successfully, however, it didn't create the "mysql" user and group accounts. I overcome this issue by manually creating these accounts. I reinstalled the "MySQL-server-5.0.10-0.glibc23.i386.rpm" RPM, and it tried to start the MySQL server, but it failed in the end. I checked the file "/var/lib/mysql/<hostname>.err" and it simply reported:

050804 14:41:55 mysqld started
050804 14:41:56 mysqld ended

I've got the same result when I used the "/etc/init.d/mysql" script to start the MySQL server. However, when I issued the command "/usr/sbin/mysqld", the server started successfully.

How to repeat:
You may do the same as described above...
[4 Aug 2005 12:27] Aleksey Kishkin
looks like diplicate of  BUG#12348 - Installation RPM fails because of groupadd on CentOS Linux.

Dimitris, could you check if installation created datadir (must be /var/lib/mysql ) and what ownership and permissions of that directories?
[4 Aug 2005 12:35] Dimitris Andrikopoulos
The RPM indeed created the directory "/var/lib/mysql" with the expected ownership
and permissions as shown below:

[root@ias9i ~]# ls /var/lib
drwxr-xr-x   4 mysql     mysql   4096 Aug  4 14:30 mysql

Also inside this directory, things were as expected:

[root@ias9i ~]# ls -l /var/lib/mysql/
-rw-rw----  1 mysql root       378 Aug  4 15:28 ias9i.cosmote.gr.err
drwx--x--x  2 mysql mysql     4096 Aug  4 14:22 mysql
drwxr-xr-x  2 mysql mysql     4096 Aug  4 14:22 test
[19 Aug 2005 13:37] Lenz Grimmer
This is most likely caused by SELinux - see BUG#12676