Bug #12076 --with-extra-charsets has no effect
Submitted: 21 Jul 2005 7:47 Modified: 8 Apr 2006 13:16
Reporter: Andrey Chesnackov Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.1.13, 4.1.15 OS:
Assigned to: Alexander Barkov

[21 Jul 2005 7:47] Andrey Chesnackov
Description:
It seems 4.1 _always_ compiled as --with-extra-charsets=complex regardless of actually specified configuration option.

Please fix that, or make it clear in documentation. As for now 
--with-extra-charsets is deprecated, and every connection to databases with native charsets will be overheaded by loading charset configuration from xml files.

How to repeat:
$ ./configure --with-charset=cp1251 --with-extra-charsets=cp1251,koi8r,koi8u,latin1,binary --with-client-ldflags=-all-static --quiet
...
$ make -s
...
$ client/mysql --character-sets-dir=/dev/null
client/mysql: Character set 'cp1251' is not a compiled character set and is not specified in the '/dev/null/Index.xml' file

Suggested fix:
Use good old MySQL 4.0 =)
[1 Sep 2005 17:40] Valerii Kravchuk
Repeated on yesterday's 4.1.15-BK build also, just as described. After "make install" I changed directory to the installation one, and:

[openxs@Fedora 4.1]$ bin/mysql -uroot --character-sets-dir=/dev/null
bin/mysql: Character set 'cp1251' is not a compiled character set and is not sp
cified in the '/dev/null/Index.xml' file

[openxs@Fedora 4.1]$ bin/mysql -uroot
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 5 to server version: 5.0.12-beta

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> use test;
Database changed
mysql> exit
Bye

(it connected to 5.0.12 running on the default port, but the problem is shown)

[openxs@Fedora 4.1]$ bin/mysql --version
bin/mysql  Ver 14.7 Distrib 4.1.15, for redhat-linux-gnu (i686) using  EditLine
wrapper
[29 Oct 2005 12:50] Andrey Chesnackov
It seems currently --with-charset= option also has no effect on libmysqlclient :(
[7 Nov 2005 6:56] Alexander Barkov
A fix has been commited into the tree.
[4 Apr 2006 10:47] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/4440
[6 Apr 2006 6:39] Alexander Barkov
Fixed in 4.1.19, 5.0.21, 5.1.9
[8 Apr 2006 13:16] Jon Stephens
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

Documented bugfix in 4.1.19, 5.0.21, and 5.1.9 changelogs. Closed.