Bug #12044 "NoOfFragmentLogFiles: 300" keeps cluster from starting.
Submitted: 20 Jul 2005 0:09 Modified: 13 Oct 2005 12:18
Reporter: Jonathan Miller Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S2 (Serious)
Version:4.1-> OS:Linux (Linux)
Assigned to: Tomas Ulin

[20 Jul 2005 0:09] Jonathan Miller
Description:
NoOfFragmentLogFiles: 300 setting will cause the cluster to crash during restart. The cluster makes it through phase 0 & 1 and goes away during phase 3. There are no core files and no errors in the cluster log. All NDBD processes exit with the same error:

Date/Time: Wednesday 20 July 2005 - 01:59:24
Type of error: error
Message: No message slogan found
Fault ID: 0
Problem data:
Object of reference: DBLQH (Line: 0) 0x0000000a
ProgramName: /home/ndbdev/jmiller/builds/libexec/ndbd
ProcessID: 20400
TraceFile: /space/run/ndb_9_trace.log.1
Version 5.1.0 (a_drop5p3)
***EOM***

Some of the error logs and trace file will be saved of to ndb08: /space/bug#### where #### == the number of this bug report.

How to repeat:
Use 6 data nodes on 3 systems, add the above to the config.ini and start cluster.

Suggested fix:
Either the cluster to come up, or a better error message, or both
[13 Aug 2005 6:10] Jonas Oreland
This is probably disk full.
300 * 64M = 19.2Gb
[15 Sep 2005 15:04] Jonathan Miller
Tomas,

Bumped NoOfFragmentLogFiles: 3000 and got back:
Date/Time: Thursday 15 September 2005 - 16:58:00
Type of error: error
Message: No message slogan found <------ Still not getting a message
Fault ID: 10
Problem data: DBLQH: File system open failed. OS errno: 2
Object of reference: DBLQH (Line: 1838) 0x0000000a
ProgramName: /home/ndbdev/jmiller/builds/libexec/ndbd
ProcessID: 1004
TraceFile: /space/run/ndb_2_trace.log.4
Version 5.1.2 (a_drop5p4)

Tomas,
Problem data: DBLQH: File system open failed. OS errno: 2
does not give the customer a clue and will result in a support call. We really need to return a good message instead of "No message slogan found". 

Thanks
JBM
[10 Oct 2005 8:41] Tomas Ulin
Fixed along with:

Bug #13197, Bug #11749, Bug #12786, Bug #11739

New and improved Error messages from 5.0.15.  Error messages not updated in 4.1.
[13 Oct 2005 12:18] Jon Stephens
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

Fix documented in 5.0.15 changelog. Closed.