Bug #12039 user acounts not storing
Submitted: 19 Jul 2005 19:26 Modified: 1 Aug 2005 12:13
Reporter: gerrit Van Acoleyen Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S1 (Critical)
Version:version 1.1.0 rc OS:Microsoft Windows (windows XP v2)
Assigned to: Vladimir Kolesnikov CPU Architecture:Any

[19 Jul 2005 19:26] gerrit Van Acoleyen
Description:
When I add or change a setting of a user acount he don't store is. When you push the button alpply changes.  Always I get the message 'Error While storing the user information.  The user might have been delted.  Plaese refreche the user list.

Passwords are never saved on the right way.

How to repeat:
Add a new user account.

Go to an other acount.
Go bak to that the new account, and change the privileges.
Try to store the info.
[19 Jul 2005 20:51] gerrit Van Acoleyen
The message that displayed

Attachment: message.jpg (image/jpeg, text), 25.27 KiB.

[19 Jul 2005 20:52] gerrit Van Acoleyen
mysql administration screen

Attachment: mysql_admin_screen.jpg (image/jpeg, text), 118.34 KiB.

[19 Jul 2005 20:53] gerrit Van Acoleyen
screen when th problem starts

Attachment: mysql_admin_store_screen.jpg (image/jpeg, text), 114.01 KiB.

[19 Jul 2005 21:14] gerrit Van Acoleyen
posts of other people

http://forums.mysql.com/read.php?103,17753
[21 Jul 2005 17:35] David Baudais
Me too. I get the same error message when adding a user using version 1.1.0.
It's a real pain. I have tried installing and uninstalling and the only user account that works is root. Any help is apprciated.
David.
[25 Jul 2005 17:25] [ name withheld ]
Me Too. Not sure whether it's a bug on a setting.
[25 Jul 2005 17:28] [ name withheld ]
If it helps any, I have a screenshot of the error that I get. This error occures after I press the "apply changes" button.
[25 Jul 2005 17:28] [ name withheld ]
http://www.clan-org.com/error/error.jpg
[26 Jul 2005 1:53] Jose Quintero
I'm having the same problem. I'm running on Windows 2000 Server. The only way that the password or user information is changed is after you restart MySQL. No other information can be changed. This is a real problem, hopefully someone will get to it.
[28 Jul 2005 17:49] Elizabeth Keen
I use MySQL Administrator version 1.1.0 on OS Windows 2000 Server w/IIS. I receive the same error.  It will create the user and the host to connect from, but it will not grant/update a user's permissions.
[28 Jul 2005 20:23] A Nelson
I just installed and have hit the same wall.  
How is anyone getting users added with privileges?
[29 Jul 2005 18:21] Neville Hobson
Exactly the same issue here, too - won't save any user changes.

I just installed MySQL 4.1.13. Running on Win XP Pro SP2, using with Movable Type 3.17.
[31 Jul 2005 4:06] Rob Davis
Don't need any simpler test cases.... I just CAN'T add a user and get the same info as posted above.  Any people out there that passed the "tough" exams able to help?
Love to test this database out a little.  Need to add users first.....
[31 Jul 2005 5:20] Scott Allen
It appears that I am having the same issue as everyone else.  I have a new Windows Server 2003 Web Edition (sp1), IIS6, ActivePerl 5.8.7.813, PHP 5.0.4, MySQL 4.1.13 and MySQL Administrator 1.1.0 rc.

I can add a user and password from the Administrator, and when I click Apply changes I get the Error while storing the user information.  When I refresh the list however the user is there.

When I assign or reassign any Schema Privileges from the MySQL Administrator, I get the Error while storing....  If I reassign privileges, all of the previously assigned privileges disappear and then I get the Error while....

The user settings that are set by the mysql monitor work just fine. They even display fine in the MySQL Administrator until you attempt to change them.

As an extremely minor aside, you have a spelling error, Schema Priviledges assigned to the User, (no d in privilege).
[31 Jul 2005 5:53] David Baudais
Hi, I upgraded to the latest beta test version and all my problems went away.

David.
[31 Jul 2005 20:26] Prasanna Mucharikar
where to find the latest beta ?
[1 Aug 2005 0:36] David Baudais
Use the MySql database server at http://dev.mysql.com/downloads/mysql/5.0.html.
This Beta Version is compatiable with the MySql Administrator software. Once I installed the new database server all my problems went away. I looks like this problem was fixed in this version of the database server.
[1 Aug 2005 12:13] Vladimir Kolesnikov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html