Bug #12011 ndb_mgmd cored on shutdown with no NDBD processes running.
Submitted: 18 Jul 2005 17:04 Modified: 20 Jul 2005 3:50
Reporter: Jonathan Miller Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S3 (Non-critical)
Version:5.1 OS:Linux (Linux)
Assigned to: Assigned Account CPU Architecture:Any

[18 Jul 2005 17:04] Jonathan Miller
Description:
I had left the ndb_mgmd process up and running over the weekend after the cluster had gone down due to dropping a table during back up. I decided to cleanup and start fresh and used the ndb_mgm -c host:port -e "shutdown" to stop the remaining ndb_mgmd process. Upon shutdown the process created a core file.

@ndb08:~/jmiller/builds/bin> ndb_mgm $ndbc -e "shutdown"
Connected to Management Server at: ndb08:14000
0 NDB Cluster storage node(s) have shutdown.
NDB Cluster management server shutdown.

#0  0x00000003 in ?? ()
#1  0x080683fe in Parser<MgmApiSession>::run(Parser<MgmApiSession>::Context&, MgmApiSession&, bool volatile*) const ()
#2  0x08064053 in MgmApiSession::runSession() ()
#3  0x400a45d0 in sessionThread_C ()
   from /home/ndbdev/jmiller/builds/lib/mysql/libndbclient.so.0
#4  0x4009aff1 in ndb_thread_wrapper ()
   from /home/ndbdev/jmiller/builds/lib/mysql/libndbclient.so.0
#5  0x400e66de in pthread_start_thread () from /lib/libpthread.so.0
(gdb) frame 1
#1  0x080683fe in Parser<MgmApiSession>::run(Parser<MgmApiSession>::Context&, MgmApiSession&, bool volatile*) const ()
(gdb) l
1       /usr/src/build/324954-i386/BUILD/glibc-2.3.2-200304020432/build-i386-linux/csu/crti.S: No such file or directory.
        in /usr/src/build/324954-i386/BUILD/glibc-2.3.2-200304020432/build-i386-linux/csu/crti.S
(gdb) exit

core file will be moved to ndb08:/space/bug#### where #### == the number of this report.

How to repeat:
Unknown

Suggested fix:
To not core.
[20 Jul 2005 3:50] Stewart Smith
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in MySQL.

Additional info:

Looks like exact duplicate of BUG#11516.