Bug #11997 Error 4336
Submitted: 18 Jul 2005 5:50 Modified: 22 Aug 2005 6:52
Reporter: mon lax Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S1 (Critical)
Version:4.1.12-1 OS:Linux (RHEL 3)
Assigned to: Assigned Account CPU Architecture:Any

[18 Jul 2005 5:50] mon lax
Description:

Case -I:
-----------

 am trying to execute the following query on a cluster with 2 NDB and 2 API nodes and one API also being a mgmt node:

CREATE TABLE `companies` (

`company_id` INT( 10 ) NOT NULL AUTO_INCREMENT ,
`company_module` INT( 10 ) NOT NULL default 0,
`company_name` varchar( 100 ) default '',
`company_phone1` varchar( 30 ) default '',
`company_phone2` varchar( 30 ) default '',
`company_fax` varchar( 30 ) default '',
`company_address1` varchar( 50 ) default '',
`company_address2` varchar( 50 ) default '',
`company_city` varchar( 30 ) default '',
`company_state` varchar( 30 ) default '',
`company_zip` varchar( 11 ) default '',
`company_primary_url` varchar( 255 ) default '',
`company_owner` int( 11 ) NOT NULL default '0',
`company_description` text NOT NULL default '',
`company_type` int( 3 ) NOT NULL DEFAULT '0',
`company_email` varchar( 255 ) ,
`company_custom` LONGTEXT,
PRIMARY KEY ( `company_id` ) ,
KEY `idx_cpy1` ( `company_owner` )
)

The error is:
#1005 - Can't create table './dotproject/companies.frm' (errno: 4336) 

Case-II
----------

CREATE TABLE `forum_watch` (
`watch_user` int(10) unsigned NOT NULL default '0',
`watch_forum` int(10) unsigned default NULL,
`watch_topic` int(10) unsigned default NULL,
KEY `idx_fw1` (`watch_user`, `watch_forum`),
KEY `idx_fw2` (`watch_user`, `watch_topic`)
) COMMENT='Links users to the forums/messages they are watching';

I get the error
#1005 - Can't create table './dotproject/forum_watch.frm' (errno: 4336)

How to repeat:

Setup a MySQL-Cluster with 2 NDB nodes, these are also the API nodes, also setup an independent MGM only node, create a table called dotproject and execute the above from command line

Suggested fix:
None
[31 Jul 2005 19:27] Jorge del Conde
Thanks for your bug report.  I was able to reproduce this in FC4
[10 Aug 2005 11:26] Pekka Nousiainen
Can't reproduce in current 4.1.x (debian).