Bug #1186 mysqld-opt 4.0.14 Assertion failure when using myodbc 3.51
Submitted: 3 Sep 2003 1:02 Modified: 29 Jan 2004 12:58
Reporter: Jim Michaels Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:3.51 OS:Microsoft Windows (win95b)
Assigned to: Heikki Tuuri CPU Architecture:Any

[3 Sep 2003 1:02] Jim Michaels
Description:
mysqld-opt 4.0.14 Assertion failure when using myodbc 3.51 to create a new user DSN for connecting to MS Access.
going through the process to create a MySQL dsn hangs MyODBC and in some cases Access needs to be forcefully terminated.
myodbc 2.5 hasn't worked well either.

C:\mysql\bin>mysqld-opt --console
InnoDB: Could not create a Windows event semaphore; Windows error 0
030902 10:52:53  InnoDB: Started
C:\MYSQL\BIN\MYSQLD~1.EXE: ready for connections.
Version: '4.0.14'  socket: ''  port: 3306
030902 19:19:12  C:\MYSQL\BIN\MYSQLD~1.EXE: Normal shutdown

030902 19:19:12  InnoDB: Starting shutdown...
030902 19:19:14  InnoDB: Assertion failure in thread 4294197369 in file C:\build
\build\mysql-4.0.14b\innobase\os\os0sync.c line 270
InnoDB: Failing assertion: CloseHandle(event->handle)
InnoDB: We intentionally generate a memory trap.
InnoDB: Send a detailed bug report to mysql@lists.mysql.com

tried to use myodbc to create a new system dsn for ms access import.
myodbc 3.51.06 hangs on first use.  win95b

my.ini:
[WinMySQLAdmin]
Server=C:/MYSQL/bin/mysqld-opt.exe
user=mysql
password=
QueryInterval=300

[mysqld]
basedir=C:/MYSQL
datadir=C:/MYSQL/data
language=C:/MYSQL/share/english
tmpdir=c:/mysql_tmp
port=3306

[mysqld-max]
basedir=C:/MYSQL
datadir=C:/MYSQL/data
language=C:/MYSQL/share/english
tmpdir=c:/mysql_tmp
port=3306
innodb_data_file_path=c:/mysql_innodbdata

[mysqld-opt]
basedir=C:/MYSQL
datadir=C:/MYSQL/data
language=C:/MYSQL/share/english
tmpdir=c:/mysql_tmp
port=3306
innodb_data_file_path=c:/mysql_innodbdata

[mysqldump]
port=3306

host=localhost
user=root

How to repeat:
start MS Access97
start mysqld-opt
install myodbc
go to control panel, ODBC32
create new user dsn
after 2nd dialog, myodbc hangs
[22 Sep 2003 0:56] Miguel Solorzano
I am changing the assignment from Venu to Heikki, because we had already
received the reported behavior with InnoDB when running on Win9x machine.
For to isolate the issue with MyODBC please do a simple test starting
the server with --skip-innodb and use the MyODBC stuff.

Regarding InnoDB I did several tests in the past and the cause was generally
machines with a poor hardware resource (RAM memory), small and not fixed
swap file type, small free hard drive space. Please verify your resources
against the memory values assigned for the InnoDB's variables in my.ini/
my.cnf configuration file.
[29 Jan 2004 12:58] Heikki Tuuri
Hi!

I have not heard this assertion failure from other Windows users.

The call should return a nonzero value:

http://msdn.microsoft.com/library/default.asp?url=/library/enus/sysinfo/base/closehandle.a...

but in this case it does not.

Win 95 never was too stable an OS. This might be some operating system bug.

This probably has nothing to do with the slow startup on Win 9x, which was fixed in 2002 by reducing InnoDB's event semaphores from 40 000 to 4000.

Regards,

Heikki