Bug #11850 MySQL preference pane does not work at startup
Submitted: 10 Jul 2005 21:59 Modified: 7 Oct 2005 2:53
Reporter: Stuart Jefferys Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.1.12 OS:Mac OS X (OS X 10.4.1)
Assigned to: Lachlan Mulcahy CPU Architecture:Any

[10 Jul 2005 21:59] Stuart Jefferys
Description:
Hope this is the correct place to report a bug in the preference pane distributed with mysql-max-4.1.12-apple-darwin7.9.0-powerpc.pkg. (It appears to have no version number of its own).

The initial state of the preference pane appears not to reflect the actual system state. Clicking stop or start generates an error the first time, and then works fine after that, until the preference app is closed.

After opening the preference application, the click-error, click-works behavior is again present.

How to repeat:
With Mysql stopped, opening the preference application and veiwing the mysql plugin pane has text that indicates the server is running, but the button says "Start MySQL Server" and the image is the stopped server image (red square on gear). Indeed, reviewing the active processes shows none owned by mysql

Clicking the Start Button produces a Systems Preferences password box requested by com.mysql.administrator.helper

After correctly entering the requested password, an error dialog is displayed by the preference application with the message: Error   Could not startup MySQL Server   Reason: Internal error

Revieing the active processes indicates that mysqld is not running.

Clicking OK and then simply trying again works, changing the picture and the status indicator to running. Interestingly, the shade of green for the text "running" gets lighter!

The password appears to have no effect on the behavior of the prefference pane. I tried waiting long enough that my password was requested on the second time, and it still worked. I also closed and the imediately reopend the preference app, and the error was still present even though the password was not asked for.

Similar behavior occurs when trying to stop the server when it is running.
[11 Sep 2005 22:29] Lachlan Mulcahy
Hi Stuart,

I have tried to repeat your issue following the steps you described using 4.1.14 and 10.4.2 with no success so far. I simply installed the server from the pkg file, installed the pane and opened it and the server status was correctly detailed as 'stopped' (in red). Attempting to start the server prompted for my password and then worked just fine.

Can you please try to reproduce the problem with 4.1.14?
[7 Oct 2005 2:53] Stuart Jefferys
Problem has gone away without change to MySQL. Possibly after an OS update to 10.4.2.
[13 Oct 2005 15:04] [ name withheld ]
I have this problem as well - and sometimes the pref pane locks up altogether. I have MAMP isntalled, but not running. Afer searching the web I found several other reports of this issue. I even tried another mySQL pref pane but that one had similar issues. 

OS X 10.4.2 / mySQL 4.1.12 running on APACHE web server

I dont know what to do about fixing this...
[30 Dec 2005 23:10] [ name withheld ]
The symptom, says "running" in green but button says start, can be replicated where starting mysqld quits right after starting due to an error. 

In my case, ownership of the mysql data folder prevented access to data files, including error logs. So the bug is, the pref pane should detect if mysqld has quit after starting up (at least where it can't really start at all). Extra credit: open a log file to display the error messages (just open any .log file with NSDesktop and it will display in Console.app).

If you're seeing this symptom, try launching mysqld_safe in the Terminal, according to documentation on this site (such as "Starting and Troubleshooting the MySQL Server"), and see what errors you get. In my case, the original problem was doing an OS X Archive and Install, which moved the /usr folder (still invisible!) to the "Previous System" folder, and when the /usr/local/ folder containing mysql was moved back to the correct place, the owner/group were apparently wrong (root:wheel instead of mysql:mysql). Setting the latter owner and group allowed mySql to be started by the preference pane (but not actually from the command line, at least the way I was doing it).