Bug #11831 ./configure successful, but when i run make, error occure
Submitted: 9 Jul 2005 6:39 Modified: 9 Jul 2005 11:26
Reporter: Cyber chiu Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Compiling Severity:S1 (Critical)
Version:4.1 source install OS:x86 Solaris 9
Assigned to: CPU Architecture:Any

[9 Jul 2005 6:39] Cyber chiu
Hi there,

./configure successful, however, when i run "make", a error show on screen :

make all-recursive
/bin/bash: make: command not found
make: *** [all] Error 127

What's wrong? My "Make" is Version 3.8 and it's work on PHP complie.

How to repeat:
Just ./configure and run make you will see...
[9 Jul 2005 11:26] Hartmut Holzgraefe
mysql, unlike PHP, uses a recursive make process 
so from within a Makefile make may be called again
to build subdirectories

looks as if you don't have make in $PATH or maybe
you just added it locally for your command shell but
didn't export it?

anyway, this is a local configuration problem, 
not a mysql bug
[10 Jul 2005 4:34] Cyber chiu
So, how can i solve this problem? I have already had the path to "make" in $PATH, when i type "whereis make" it do show the correct path... please advice the steps as i know it's not the mysql bug now but i still can make it...
[10 Jul 2005 4:35] Cyber chiu
Opps.. not still can make it, is still can't make it