Bug #11712 Error creating CREATE Statment with MS-Access DB
Submitted: 3 Jul 2005 16:12 Modified: 6 Jul 2005 18:19
Reporter: Beat Arnet Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S2 (Serious)
Version:1.0.9 beta OS:Microsoft Windows (Win XP, SP2)
Assigned to: CPU Architecture:Any

[3 Jul 2005 16:12] Beat Arnet
Description:
Initializing JDBC driver ... 
Driver class MySQL JDBC Driver 3.1
Opening connection ... 
Connection jdbc:mysql://localhost:3306/?user=test&password=test&useServerPrepStmts=false
Deactivate foreign key constraints.
SET FOREIGN_KEY_CHECKS = 0;
Drop schema Balance_d if it already exists.
DROP DATABASE IF EXISTS `Balance_d`;
Creating schema Balance_d ...
CREATE DATABASE `Balance_d`
  CHARACTER SET latin1 COLLATE latin1_swedish_ci;
Creating tables ...
Creating table datallgbemerkungen ...
CREATE TABLE `Balance_d`.`datallgbemerkungen` 
)
ENGINE = INNODB;
An error occured while executing the SQL statement.
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')
ENGINE = INNODB' at line 2
Creating table datartikel ...
CREATE TABLE `Balance_d`.`datartikel` 
)
ENGINE = INNODB;
An error occured while executing the SQL statement.
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')
ENGINE = INNODB' at line 2
Creating table datbau ...
CREATE TABLE `Balance_d`.`datbau` 
)
...

No table was created. Worked with version 1.0.7 beta

How to repeat:
Migrate any MS-Access 2000 Database.
[4 Jul 2005 17:10] Miguel Solorzano
Could you please provide an mdb example file which fails to migrate.
Sometimes building our own mdb not shows the errors reported.

Thanks in advance.
[6 Jul 2005 3:38] Jorge del Conde
Hi!

Can you please upload the schema of the table that fails ?  I was unable to reproduce this bug with a randomly created table.
[28 Aug 2005 13:45] Beat Arnet
Same error with version 1.0.14 rc