Bug #11576 Can't compile 4.0 w/FC 4
Submitted: 25 Jun 2005 21:53 Modified: 19 Oct 2005 23:32
Reporter: Jorge del Conde Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Compiling Severity:S2 (Serious)
Version:4.0 OS:Linux (Linux - Fedora 4)
Assigned to: Jim Winstead CPU Architecture:Any

[25 Jun 2005 21:53] Jorge del Conde
Description:
I can't get past the configure stage in mysql 4.0.

running ./configure [options] produces the following error:

checking "LinuxThreads" ... "Not Found"
configure: error: This is a linux system and Linuxthreads was not found.  On linux Linuxthreads should be used.  Please install Linuxthreads (or a new glibc) and try again.  See the Installation chapter in the Reference Manual for more information.

Obviously, glibc is the newest available, and Linuxthreads *is* installed.

Neither 4.1 or 5.0 had this problem.

How to repeat:
read above
[6 Jul 2005 1:28] [ name withheld ]
Not that it will help any, but I've run into the exact same error.

I tried these too:
./configure --prefix=/usr/local/mysql  --with-mit-threads=/usr/include
get
"END OF INNODB CONFIGURATION
Configuring MIT Pthreads
./configure: line 33690: cd: mit-pthreads: No such file or directory"

./configure --prefix=/usr/local/mysql --with-named-thread-libs=/usr/include
and
./configure --prefix=/usr/local/mysql --with-mit-threads=/usr/include/linuxthreads --with-named-thread-libs=/usr/include
and
./configure --prefix=/usr/local/mysql --with-mit-threads=/usr/include --with-named-thread-libs=/usr/include
get same error for all three
"checking size of char... configure: error: cannot compute sizeof (char), 77
See 'config.log' for more details."
[6 Jul 2005 2:26] Miguel Solorzano
Looks like the same issue as:

http://bugs.mysql.com/bug.php?id=9497

A work-around should be:

"add somewhere "Linuxthreads" in /usr/include/pthread.h"
[19 Oct 2005 23:28] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/31267
[19 Oct 2005 23:32] Jim Winstead
The patch can be used to get 4.0 to compile 4.0 on FC4, but this is not a configuration we will support, and the patch will not ever be incorporated into the 4.0 tree. MySQL 4.1 and later work just fine on FC4, and 4.1 has been the recommended production release for nearly a year now.