Bug #115354 MySQL installation fails due to internet connectivity
Submitted: 17 Jun 8:31 Modified: 18 Jun 13:26
Reporter: Praveen Kumar B A Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.7.42, 8.0.35 OS:Windows
Assigned to: CPU Architecture:Any

[17 Jun 8:31] Praveen Kumar B A
Description:
MySQL server installation fails with below error due internet connectivity on windows machine.
"Unknown suffix '.' used for variable 'mysqlx-port' (value '0.0')."

This happens with both GUI and commandline based installation of MySQL server.
And it occurred for both versions 5.7.42 and above, 8.0.35 and above.

Logs:
-----
Beginning configuration step: Initializing database (may take a long time)

Attempting to run MySQL Server with --initialize-insecure option...
Starting process for MySQL Server 8.0.35...
Starting process with command: C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe --defaults-file="C:\ProgramData\MySQL\MySQL Server 8.0\my.ini" --console --initialize-insecure=on --lower-case-table-names=1...
C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe (mysqld 8.0.35) initializing of server in progress as process 6492
Unknown suffix '.' used for variable 'mysqlx-port' (value '0.0').
option 'mysqlx-port': unsigned value 0 adjusted to 1.
C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe: Error while setting value '0.0' to 'mysqlx-port'.
Parsing options for plugin 'mysqlx' failed.
InnoDB initialization has started.
InnoDB initialization has ended.
unknown variable 'mysqlx_port=0.0'.
The newly created data directory C:\ProgramData\MySQL\MySQL Server 8.0\Data\ by --initialize is unusable. You can remove it.
Aborting
C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe: Shutdown complete (mysqld 8.0.35)  MySQL Community Server - GPL.
Process for mysqld, with ID 6492, was run successfully and exited with code 1.
Failed to start process for MySQL Server 8.0.35.

How to repeat:
We have seen this issue on several windows machine and it is easily reproducible.

Step 1: Reserve a windows machine
Step 2: Download mysql community installer (mysql-installer-community-X.X.X.X.msi) 8.0.35 or 5.7.42 and above from https://downloads.mysql.com/archives/installer/
Step 3: Install MySQL server from any medium

Failure logs are mentioned above.
[17 Jun 8:31] Praveen Kumar B A
Failure MySQL Installation logs

Attachment: MySQL_Installation.txt (text/plain), 2.51 KiB.

[17 Jun 9:35] MySQL Verification Team
Hi Mr. Kumar,

Thank you for your bug report.

We tried with the release 8.0.37 and we could not repeat the problem.

Can you please tell us whether you experience the same with 8.0.37.

If you do, please let us know which GUI did you use exactly and what options have you passed it to.

Many thanks in advance.
[17 Jun 20:22] Rainer Sprenger
I have exactly the same error, now on 3 different Windows PCs with win 10 and 11.
I tried at least 15 different port parameterizations. None works.
I tried different server versions: 8.0.35, 8.0.36, 8.0.37 and 5.7.42. None works.
The error
[ERROR] [MY-000058] [Server] Unknown suffix '.' used for variable 'mysqlx-port' (value '0.0').
in the error log is always the same with me as already posted in the description.

The last 2 lines in my.ini are
# The TCP/IP Port the MySQL Server X Protocol will listen on.
mysqlx_port=0.0

my.ini is repeatedly overwritten during installation.

Starting the server with "net start mysql80" and corrected my.ini (mysqlx_port=33060) results in subsequent errors.

I haven't changed the GUI version: 1.6.9.0 since the last successful installation several weeks ago.

There was no successful Windows update on my PC.
[17 Jun 20:25] Rainer Sprenger
Sorry, I forgot to say that I have had the error since June 14th, 2024.
[18 Jun 10:17] MySQL Verification Team
Hi,

Setting mysqlx_port that way is an error ........

Please, read our Reference Manual:

mysqlx_port

Command-Line Format	--mysqlx-port=port_num
System Variable	mysqlx_port
Scope	Global
Dynamic	No
SET_VAR Hint Applies	No
Type	Integer
Default Value	33060
Minimum Value	1
Maximum Value	65535

----------------------------------

Hence, imysqlx_port accepts only integer values.

Try to set it manually when installing, using the options that come with GUI Installer.

Also, the category of this report is wrong.

This is not "MySQL Server" related problem.
[18 Jun 10:24] MySQL Verification Team
Hi,

We followed a default procedure with GUI installer that came with 8.0.37, with no options and we could not repeat your problem.
[18 Jun 13:21] Rainer Sprenger
I tried reinstalling MySql again:

1. In the Installer Catalog updated and installed the latest Installer (1.6.11.0).
2. All existing components including the data removed.
3. Did a full install (with the offered server 8.0.32)
4. The message „Workbench path exists“ ignored.
5. The installation went through without any errors!!! (the first time since 5 days)
6. Imported the dump with my data via the workbench.
7. Update to the latest versions (Server 8.0.37) carried out.
8. Workbench started and tried to connect to the server ==>>
   Password request. The correct password was not accepted

With every attempt to give the correct password the following message in the Error.log:
2024-06-18T12:46:52.558929Z 15 [Warning] [MY-013360] [Server] Plugin mysql_native_password reported: ''mysql_native_password' is deprecated and will be removed in a future release. Please use caching_sha2_password instead'

Previously there were the following interesting entries in the Error.log:
2024-06-18T12:02:29.582152Z 0 [Warning] [MY-011070] [Server] '--sync-relay-log-info' is deprecated and will be removed in a future release.

And especially:
2024-06-18T12:02:30.237993Z 0 [ERROR] [MY-010901] [Server] Can't open shared library 'C:\Program Files\MySQL\MySQL Server 8.0\lib\plugin\auth_socket.so' ( errno: 126 The specified module was not found.).

Restarting the PC leads to the same steps/messages as from step 8.

What can I do?
[18 Jun 13:26] MySQL Verification Team
Hi,

In 8.0, native passwords are deprecated.

You should create a user with SSL encrypted password.

The entire procedure is described in our Reference Manual.

You are supposed to read the all relevant parts of that Manual, prior to reporting a bug.

Furthermore, this a forum for the bugs with a repeatable test cases.

This is not a forum for support.

Not a bug.
[18 Jun 15:31] Rainer Sprenger
Hello,
Thanks for the informations.

Unfortunately I have to reinstall MySql because the database crashed for a reason I don't know. But I'm a normal user who just uses the normal functions of the GUI installer without changing any of the default settings. But this no longer works! It had worked exactly the same way on various systems so far.
I've been searching intensively for a solution for 5 days and yesterday I came across this bug report that describes my problem exactly. I have only added my findings to the description of the bug to help you troubleshoot.

When installing, I left the “Authentication Method” unchanged as “Use Strong Password Encryption …”. But something goes wrong and that seems to be a bug. And the Reporter (Praveen Kumar) seems to have the same problem.
[18 Jun 15:34] MySQL Verification Team
Hi,

This is a forum for the reports with fully repeatable test cases.

We have not been able to repeat your problem(s).
[18 Jun 15:35] MySQL Verification Team
If you wish we can also provide you with the links for the free and paid MySQL support.