Bug #115322 Mysql server is crashing on startup
Submitted: 13 Jun 17:36 Modified: 14 Jun 9:17
Reporter: orcun yilmaz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.30 OS:Oracle Linux (9.4)
Assigned to: CPU Architecture:x86 (48core)

[13 Jun 17:36] orcun yilmaz
Description:
You can find the stack trace below. 

2024-06-11T19:00:07.372479+03:00 321152229 [ERROR] [MY-013183] [InnoDB] Assertion failure: row0ins.cc:1654:cmp < 0 thread 140352354674240
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/8.0/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
16:00:07 UTC - mysqld got signal 6 ;
Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.
Thread pointer: 0x7f5261d29750
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fa6543e5c58 thread_stack 0x100000
/usr/sbin/mysqld(my_print_stacktrace(unsigned char const*, unsigned long)+0x41) [0x14e4d11]
/usr/sbin/mysqld(print_fatal_signal(int)+0x2dc) [0xb1c22c]
/usr/sbin/mysqld(my_server_abort()+0x7e) [0xb1c35e]
/usr/sbin/mysqld(my_abort()+0xe) [0x14e085e]
/usr/sbin/mysqld(ut_dbg_assertion_failed(char const*, char const*, unsigned long)+0x183) [0x16905a3]
/usr/sbin/mysqld(row_ins_check_foreign_constraint(bool, dict_foreign_t*, dict_table_t*, dtuple_t*, que_thr_t*)+0xd9e) [0x1630dfe]
/usr/sbin/mysqld() [0x1630f41]
/usr/sbin/mysqld(row_ins_sec_index_entry(dict_index_t*, dtuple_t*, que_thr_t*, bool)+0x40) [0x1645130]
/usr/sbin/mysqld(row_ins_step(que_thr_t*)+0x42c) [0x1647d9c]
/usr/sbin/mysqld() [0x164852d]
/usr/sbin/mysqld(ha_innobase::write_row(unsigned char*)+0x2ae) [0x15425ae]
/usr/sbin/mysqld(handler::ha_write_row(unsigned char*)+0x152) [0xc088e2]
/usr/sbin/mysqld(Write_rows_log_event::write_row(Relay_log_info const*, bool)+0x12d) [0x128aa9d]
/usr/sbin/mysqld(Write_rows_log_event::do_exec_row(Relay_log_info const*)+0x1d) [0x128ae9d]
/usr/sbin/mysqld(Rows_log_event::do_apply_row(Relay_log_info const*)+0x2a) [0x12712ea]
/usr/sbin/mysqld(Rows_log_event::do_apply_event(Relay_log_info const*)+0x9d2) [0x1294f02]
/usr/sbin/mysqld(slave_worker_exec_job_group(Slave_worker*, Relay_log_info*)+0x2a9) [0x1312f09]
/usr/sbin/mysqld() [0x131724b]
/usr/sbin/mysqld() [0x18d95b6]
/lib64/libc.so.6(+0xa46d2) [0x7fd8d9ef46d2]
/lib64/libc.so.6(+0x443f0) [0x7fd8d9e943f0]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (0): Connection ID (thread ID): 321152229
Status: NOT_KILLED

How to repeat:
It is not possible to reproduce this bug.
[14 Jun 9:17] MySQL Verification Team
Hi Mr. vilmaz,

Thank you very much for your bug report.

However, your bug report is the identical bug report which is already verified. That bug report also contains entire test case.

Your bug report is a duplicate of:

https://bugs.mysql.com/bug.php?id=105290

Since that bug report has a test case, it is not visible to public, for security reasons.

However, we have left a comment in that bug that you are informed when that bug is fixex.

Duplicate
[14 Jun 15:57] MySQL Verification Team
Bug #105290 is marked as duplicate of this one
[17 Jun 9:39] MySQL Verification Team
Hence, both. of the bugs are duplicates of the following original bug:

https://bugs.mysql.com/bug.php?id=105290