Bug #11532 Views reported as tables in SQLServer Linked server
Submitted: 23 Jun 2005 15:53 Modified: 23 Jun 2005 20:28
Reporter: [ name withheld ] (Basic Quality Contributor) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:5.0.6 OS:Microsoft Windows (winxp)
Assigned to: CPU Architecture:Any

[23 Jun 2005 15:53] [ name withheld ]
Description:
Created a linked server from SQLServer 2000 sp4 to MySQL 5.0.6 using System DSN and MyODBC 3.51.
I can successfully connect and see tables, "views" is empty, views present in mysql are reported as tables in SQLServer's linked server.

How to repeat:
See above.
[23 Jun 2005 20:28] Miguel Solorzano
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.mysql.com/documentation/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php
[24 Jun 2005 10:14] [ name withheld ]
Thanks for you answer, but this IS a bug unless you point me to some docs that states that by design mysql's views are reported as tables in linked servers.
Note that Firebird and PostgreSQL's views are correctly shown as views.
I know that this does not pose a mayor functional limitation but it's anyway annoying.