Bug #115188 Failures trying to modify database mysql and table user
Submitted: 31 May 18:15 Modified: 3 Jun 9:33
Reporter: David Pfender Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.4.0 OS:Windows (10 Pro)
Assigned to: CPU Architecture:Any

[31 May 18:15] David Pfender
Description:
Because the MySQL Workbench program is no longer compatible with the latest version of the MySQL Server (8.4.0), I decided to program my own workbench to be used on my Windows 10 Pro system.

I wanted to manage the user entries in the mysql database.  I began having unusual failures trying to change the password of a user after a recent rename of the user.  I thought that my program had the problem, but then discovered that I can demonstrate the problem with the command-line mysql program.  Therefore, the problem is in the MySQL Server.  The sequence of queries is not unusual so the problem must be serious.  So far, I have not seen this problem in other website programs that I support, but this problem needs a serious investigation to determine the real impact.

Also, the sequence of creating a user, deleting the user and then creating the same user again will cause a failure.  Using the same create query again will then succeed.

I have attached two files.
One is a text file with the sequence of queries with comments that demonstrate the problem.
The other is a text file showing the command-line output from the mysql program for execution of these queries.

Be sure to stop and start the database server before running the queries to have consistent results.

How to repeat:
Rerun the example output.
[31 May 18:17] David Pfender
result of running queries that show the problem

Attachment: mysql_bug_output.txt (text/plain), 3.80 KiB.

[3 Jun 9:33] MySQL Verification Team
Hi Mr. Pfender,

Thank you for your bug report.

However, it is not a bug.

Creating a data dictionary is not done in the way that you are soing it.

Our Development does it in the completely different manner.

Not a bug.
[3 Jun 9:49] MySQL Verification Team
Hi Mr. Pfender,

We have taken a closer look at your report.

Our Reference Manual states clearly that nobody should not meddle with tables in mysql schema directly. They are dependent on each other and DML changes do not refresh the cache.

Instead, you  must always use appropriate DDLs to modify user properties.

Not a bug.