Bug #115167 Unhandled exception: 'ascii' codec can't decode byte 0xef in position 0: ordinal
Submitted: 29 May 15:48 Modified: 2 Jun 8:02
Reporter: Ritika Das Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.34 OS:MacOS (Macos Sonoma)
Assigned to: CPU Architecture:Any

[29 May 15:48] Ritika Das
When trying to import a CSV file using the wizard i get the following error:
Unhandled exception: 'ascii' codec can't decode byte 0xef in position 0: ordinal not in range (128).

I cannot load any CSV files to my database at the moment.

I have seen this problem posted online but so far no useful solution.

This is related to another bug- https://bugs.mysql.com/bug.php?id=87788
But the solution given above also doesn't work.

How to repeat:
1. Inside workbench, right click on the schema and select Table Data Import Wizard.
2. Browse the csv file and click on next.
3. Select create new table option with default name and click on next.
4. getting error - Unhandled exception: 'ascii' codec can't decode byte Oxe2 in position 2485: ordinal not in range(128).

Note: the position changes.
I have tried with multiple csv files
Encoding selected by default - utf-8

Suggested fix:

Tried fixes from above link but nothing worked.
Also, deleted the headers and re-wrote them but it didn't work.
[30 May 11:44] MySQL Verification Team
Hello Ritika,

Thank you for the bug report.
Imho this is duplicate of Bug #95700, please see Bug #95700.

Ashwini Patil
[2 Jun 8:02] Ritika Das
Hi Ashwini,
No solution has been provided on the bug referred by you- https://bugs.mysql.com/bug.php?id=95700.
Kindly provide a working solution to my issue.