Bug #115098 different precision in MySQL5.7.42andMySQL8.3.0
Submitted: 23 May 12:39 Modified: 23 May 13:35
Reporter: Ecee no Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.3.0 OS:Any
Assigned to: CPU Architecture:Any

[23 May 12:39] Ecee no
Description:
It is my testcase as follow, in MySQL5.7.42, column type is decimal(6,3), but in MySQL8.30´╝îcolumn type is decimal(5,3).

How to repeat:
drop table if exists t;
create table t as select 009.123;
select * from t;
show create table t;

-- MySQL5.7.42
decimal(6,3)

-- MySQL8.3.0
decimal(5,3)

Suggested fix:
I wanna know whether it's a bug, maybe expect decimal(6,3)?
[23 May 13:35] MySQL Verification Team
Hi Mr. no,

Thank you for your bug report.

However, this is not a bug.

Simply 8.0 is more precise, for your example, in this respect then 5.7 .

Not a bug.