Bug #114831 MySQL-Workbench missing in Repos
Submitted: 1 May 5:41 Modified: 4 May 4:32
Reporter: Dennis Kriechel Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Workbench Severity:S2 (Serious)
Version: OS:Ubuntu (Jammy)
Assigned to: CPU Architecture:x86 (amd64)

[1 May 5:41] Dennis Kriechel
Since yesterday it seems like the mysql-repo is incomplet. I have an installation script that:
 1. Downloads the latest mysql-apt-config.deb
 2. Adds the DEB locally
 3. Try to install mysql-workbench-community

Suddenly in step 3, I receive the following Message: "E: Unable to locate package mysql-workbench-community"

Checking the Repo-Files e.g. http://repo.mysql.com/apt/ubuntu/dists/jammy/InRelease or http://repo.mysql.com/apt/ubuntu/dists/jammy/mysql-tools/binary-amd64/Packages there is no Workbench anymore. The Last Update to this file was applied at 29 Apr 2024 09:21:41 UTC, so since this time it seems like workbench was missing from the repo. The day before everything was fine.

How to repeat:
You can use a simple Docker-File to reproduce the Problem. Add the following to file called "Dockerfile"

FROM ubuntu:jammy

RUN apt-get update
RUN apt-get install -y wget openssl

RUN wget --no-check-certificate -O mysql-apt-config.deb "https://dev.mysql.com/get/mysql-apt-config_0.8.29-1_all.deb"

RUN apt-get install -y lsb-release gnupg
RUN dpkg -i mysql-apt-config.deb
RUN apt-get update
RUN apt-get install -y mysql-workbench-community


Then run: "docker build ." and you will the error-message: "E: Unable to locate package mysql-workbench-community"

Suggested fix:
Add mysql-workbench-community back to the repos please.
[3 May 12:16] MySQL Verification Team
Hello Dennis Kriechel,

Thank you for the bug report.
We were informed that this was true on release day, but eventually it was remedied the next day with a metadata refresh and WB 8.0.36 is now available when mysql-8.0 is selected. So it should be working now.


Ashwini Patil
[3 May 13:17] Dennis Kriechel
It's still not working, can you please run my testcase it still fails.
[3 May 22:22] Philip Olson
I've not run your code but suspect Workbench is not available because MySQL 8.4 is now enabled by default rather than MySQL 8.0, and Workbench is only available with MySQL 8.0. Enabling MySQL mysql-8.0 rather than using the default mysql-8.4-lts is what makes Workbench available.
[4 May 4:32] Dennis Kriechel
Ah thanks for pointing that out, you are right!

I think a lot of documentation out there needs to be updated then, since all the existing Tutorials are based on the mysql-apt-config.deb, which is based on default an therefore not working anymore for mysql-workbench.

But here is how it works now:


FROM ubuntu:jammy

RUN UBUNTU_VERSION=$(cat /etc/os-release | grep UBUNTU_CODENAME | sed 's/UBUNTU_CODENAME=//') && \
    echo "deb [trusted=yes] http://repo.mysql.com/apt/ubuntu/ jammy mysql-8.0" >> /etc/apt/sources.list.d/mysql.list && \
apt-get update

RUN apt-get install -y mysql-workbench-community