Bug #114700 reverse engineer - crashing
Submitted: 19 Apr 9:51 Modified: 19 Apr 11:59
Reporter: kevin holm Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.36 OS:Windows (Microsoft Windows 10 Enterprise)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[19 Apr 9:51] kevin holm
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\kelh\AppData\Roaming\MySQL\Workbench\log\wb.log]

Trying to use "reverse engineer" crashes and exits Mysql Workbench without giving any error handling.

How to repeat:
Open Mysql Workbench

select databases/Reverse engineer...

choosing default connection - Standard (TCP/IP)

click next button and crash where Mysql Workbench without giving any error handling occurs.

the crash also happens i i try to change connection method and if i connect to the database before trying to reverse engineer.

Suggested fix:
Let me know if i can provide some more useful logs?
[19 Apr 11:46] MySQL Verification Team
Hello Kevin,

Thank you for the bug report.
I tried to reproduce your issue on windows 11 with workbench 8.0.36 but I am not seeing any issues at my end.
Please see the screenshot attached.

Regards,
Ashwini Patil
[19 Apr 11:48] MySQL Verification Team
8.0.36 test results

Attachment: 114700_test_results.png (image/png, text), 128.04 KiB.

[19 Apr 11:59] kevin holm
Hi Ashwini,

Thanks for the help, how do we advance from this? I still have the bug and it is consistent on my Windows 10 system.

Best regards

Kevin
[19 Apr 12:14] MySQL Verification Team
Hello Kevin,

Imho, this issue may be due to non-English user language pack. 
Let me test with Danmark language pack and get back to you. Thanks.

Regards,
Ashwini Patil