Bug #114461 Problematic color themes MySQL Workbench 8.0.36 on MacOS Sonoma 14.4
Submitted: 23 Mar 9:38 Modified: 25 Mar 14:14
Reporter: Serdar Tas Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.36 OS:MacOS (Sonoma 14.4)
Assigned to: CPU Architecture:ARM (Apple M1 Pro)
Tags: diagram, invisible buttons, theme, theme colors, unreadable buttons, unreadable text

[23 Mar 9:38] Serdar Tas
Description:
No matter which default theme is selected in MacOS, when diagraming on MySQL Workbench, many icons or text are shown in same colour with the background, making it near impossible to use the software. 

How to repeat:
Install MySQL Workbench on MacOS and create a new model -> diagram
[23 Mar 9:39] Serdar Tas
Invisible icons - dark theme

Attachment: Screenshot 2024-03-23 at 10.33.58.png (image/png, text), 678.08 KiB.

[23 Mar 9:40] Serdar Tas
Invisible Icons - Light Theme

Attachment: Screenshot 2024-03-23 at 10.35.19.png (image/png, text), 571.07 KiB.

[23 Mar 9:40] Serdar Tas
Invisible Text - Table Name - Dark Theme

Attachment: Screenshot 2024-03-23 at 10.34.51.png (image/png, text), 231.19 KiB.

[23 Mar 9:41] Serdar Tas
Invisible Text - Table Name - Light Theme

Attachment: Screenshot 2024-03-23 at 10.35.07.png (image/png, text), 332.18 KiB.

[25 Mar 11:39] MySQL Verification Team
Hello Serdar Tas,

Thank you for the bug report.
Imho this is duplicate of Bug #113653, please see Bug #113653.

Regards,
Ashwini Patil
[25 Mar 14:14] Serdar Tas
Fair enough. Yet I'm unable to find a workaround to this