Bug #114451 Missing option for "RESET SOURCE"
Submitted: 22 Mar 12:20 Modified: 22 Mar 13:54
Reporter: IGG t Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.36 OS:Any
Assigned to: CPU Architecture:Any

[22 Mar 12:20] IGG t
Description:
When setting up a new replica database today I noticed that we seem to be missing the option for "RESET SOURCE".

The older "RESET MASTER" is still working.

(RESET REPLICA appears to exist and work fine)

How to repeat:
Log into MySQL
execute the command "RESET SOURCE;"

Suggested fix:
Add this as a valid option
[22 Mar 13:54] MySQL Verification Team
Hi Mr. t,

Thank you for your bug report.

MySQL never had RESET SOURCE ....... instead of that command, you have the following options:

https://dev.mysql.com/doc/refman/8.0/en/reset-replica.html

https://dev.mysql.com/doc/refman/8.0/en/reset-master.html

https://dev.mysql.com/doc/refman/8.0/en/replication-multi-source-adding-gtid-master.html

Not a bug.
[25 Mar 20:17] Frederic Descamps
Hi, 

The new syntax replacing RESET M*ST*R is now (since 8.3) the following:

RESET BINARY LOGS AND GTIDS;

see https://dev.mysql.com/doc/refman/8.3/en/reset-binary-logs-and-gtids.html

Regards,
[26 Mar 12:49] MySQL Verification Team
Thank you, Frederic.