Bug #114443 GUI is missing some parts
Submitted: 21 Mar 13:00 Modified: 21 Mar 13:08
Reporter: Roberto Segura Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.36 OS:MacOS (Apple M2 Pro)
Assigned to: CPU Architecture:ARM
Tags: mac m2, Mac OS

[21 Mar 13:00] Roberto Segura
Description:
When opening MySQL Workbench on my new Macbook m2 pro the GUI is totally broken. There are missing parts (Cannot edit the table name or see the foreign keys)., When clicking Schema Privileges tables are gone and never shown again. I've tried to downgrade to all version until 8.0.34 and none of them work. I've removed all the data (cache, etc.) between installations and still nothing. 

I've tried the solution proposed in https://bugs.mysql.com/bug.php?id=92141 but it does not work.

How to repeat:
1. Open MySQL Workbench
2. Go to File > New Model
3. Create a table
4. You cannot edit the table name or see any of the options of the table
5. Click on Schema Privleges. Now your tables are gone!

Suggested fix:
It's related to the GUI because it shows corrupted sections.
[21 Mar 13:07] Roberto Segura
A company mate has the same laptop and the same failure: cannot edit table name, see foreign hey buttons and clicking on Schema Privileges makes tables to dissapear
[21 Mar 13:08] Grant Glendinning
Followed step 1, created a table

Attachment: Screenshot 2024-03-21 at 13.03.17.png (image/png, text), 688.64 KiB.

[21 Mar 13:08] MySQL Verification Team
Hello Roberto,

Thank you for the bug report.
Imho this is duplicate of Bug #113653, please see Bug #113653.

Regards,
Ashwini Patil
[21 Mar 13:08] Grant Glendinning
Table view is now gone after clicking Schema Privileges

Attachment: Screenshot 2024-03-21 at 13.07.07.png (image/png, text), 550.34 KiB.