Bug #114358 Access denied when SECONDARY connect to PRIMARY
Submitted: 14 Mar 18:21 Modified: 15 Mar 20:28
Reporter: Bing Ma (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Operator Severity:S1 (Critical)
Version:2.1.1 OS:Any
Assigned to: MySQL Verification Team CPU Architecture:Any

[14 Mar 18:21] Bing Ma
Description:
when a SECONDARY connect to PRIMARY, the PRIMARY log shows:

2024-03-14T18:01:55.344212Z 3235157 [Warning] [MY-013360] [Server] Plugin sha256_password reported: ''sha256_password' is deprecated and will be removed in a future release. Please use caching_sha2_password instead'
2024-03-14T18:01:55.345787Z 3235157 [Note] [MY-010926] [Server] Access denied for user 'mysql_innodb_cluster_1002'@'mgr-2.mgr-instances.my-namespace.svc.cluster.loca' (using password: YES)
2024-03-14T18:01:55.434590Z 3235158 [Warning] [MY-013360] [Server] Plugin sha256_password reported: ''sha256_password' is deprecated and will be removed in a future release. Please use caching_sha2_password instead'
2024-03-14T18:01:55.437663Z 3235158 [Note] [MY-010926] [Server] Access denied for user 'mysql_innodb_cluster_1002'@'mgr-2.mgr-instances.my-namespace.svc.cluster.loca' (using password: YES)

---
mgr-2 is the node want to join the group

---
in the PRIMARY,thers is no mysql_innodb_cluster_1002 user in mysql.user:

select user,host from mysql.user;
+---------------------------+-----------+
| user                      | host      |
+---------------------------+-----------+
| kpanda                    | %         |
| mysql_innodb_cluster_1000 | %         |
| mysql_innodb_cluster_1001 | %         |
| mysqladmin                | %         |
| mysqlbackup               | %         |
| mysqlrouter               | %         |
| root                      | %         |
| localroot                 | localhost |
| mysql.infoschema          | localhost |
| mysql.session             | localhost |
| mysql.sys                 | localhost |
| mysqlhealthchecker        | localhost |
| mysqlmetrics              | localhost |
+---------------------------+-----------+

---
the group has two nodes: mgr-0 and mgr-1, mgr-0 is the PRIMARY

How to repeat:
I don't know how to repeat this
[14 Mar 18:22] Bing Ma
there is a weird thing in the log 
Access denied for user 'mysql_innodb_cluster_1002'@'mgr-2.mgr-instances.my-namespace.svc.cluster.loca

---
I think this should be:
Access denied for user 'mysql_innodb_cluster_1002'@'mgr-2.mgr-instances.my-namespace.svc.cluster.local

the last "l" missed
[14 Mar 19:18] Bing Ma
I fix by this:

cluster.addInstance('mgr-2.mgr-instances.my-namespace.svc.cluster.local')
[15 Mar 20:28] MySQL Verification Team
Hi, this is not a bug. If you need help configuring / using MySQL products please contact MySQL Support team.