Bug #11427 bytefx to connector 1.0.4 problem with SQL_BIG_SELECTS
Submitted: 18 Jun 2005 15:19 Modified: 1 Sep 2006 10:56
Reporter: Christian Emond Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:1.0.4 OS:Microsoft Windows (windows xp)
Assigned to: Assigned Account CPU Architecture:Any

[18 Jun 2005 15:19] Christian Emond
Description:
Hi,
   at my job we've using vb.net with mysql database

The driver i was using was bytefx

Since we moved to connector/net to have more flexibility, a faster website and being up to date i got this problem in some aspx page who got long select statement. I know the problem is not from mysql cause i can execute them in the query browser or simply in my code with the bytefx driver

At the moment that i move to connector/net 1.0.4 i got this problem :

"The SELECT would examine more than MAX_JOIN_SIZE rows; check
your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay"

Please if you can give me a solution i would appreciate a lot

Thanks
Christian

How to repeat:
It's only when i execute a page with a lot of left join
The page won't never open and tell me this error :

"The SELECT would examine more than MAX_JOIN_SIZE rows; check
your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay"
[20 Jun 2005 9:30] Vasily Kishkin
Could you please write some test case with big select and definitions of tables ?
[20 Jun 2005 16:23] Christian Emond
it is with big select as this one i got problem.

But, as i said, with the bytefx everything work fine.

commande = New mysqlCommand("Select ass_telephone.*, vlan_telephone.no_vlan, locaux.no_complet_local, prise.no_prise, no_telephone FROM (((ass_telephone LEFT JOIN locaux ON ass_telephone.id_local = locaux.id_local) LEFT JOIN prise ON locaux.no_local = prise.no_local) LEFT JOIN no_telephone ON ass_telephone.id_dn1 = no_telephone.no_dn ) LEFT JOIN vlan_telephone ON ass_telephone.id_vlan = vlan_telephone.id_vlan Where ass_telephone.id_telephone = 5 ", conn)

Thanks
Christian
[22 Jun 2005 21:46] Christian Emond
any idea??
[22 Jun 2005 22:35] Reggie Burnett
Christian

Can you create a simple function that shows the problem and send it and your table structure to me?  I'll then try to reproduce it right away and fix it if there is   a bug.

Thanks
[22 Jul 2005 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[1 Sep 2006 7:53] Brayan Johnes
I have the same problem but with Connector/Net 1.0.7
[1 Sep 2006 10:56] Shane Bester
This looks like a duplicate of bug #20023
Please disable connection pooling and see if problem goes away.