Bug #114264 Check for Updates
Submitted: 7 Mar 15:46 Modified: 8 Mar 12:20
Reporter: Ulf Borjesson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.36 OS:Windows (Microsoft Windows Server 2019 Standard)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[7 Mar 15:46] Ulf Borjesson
Description:
When running the Check for Updates in Workbench it fails. 

How to repeat:
10:34:26 [ERR][      Workbench]: Console redirection failed.
10:34:26 [INF][      Workbench]: Starting up Workbench
10:34:26 [INF][      Workbench]: Current environment:
	Command line: "F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE\MySQLWorkbench.exe" 
	CurrentDirectory: F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE
	HasShutdownStarted: False
	OSVersion: Microsoft Windows NT 6.2.9200.0
	SystemDirectory: C:\Windows\system32
	TickCount: 1880483875
	UserInteractive: True
	Version: 4.0.30319.42000
	WorkingSet: 36335616
10:34:26 [INF][      Workbench]: Environment variables:
	myDestPath = C:\Temp
	mySentinel = No
	USERDNSDOMAIN = NET.UCF.EDU
	ProgramW6432 = C:\Program Files
	PROCESSOR_IDENTIFIER = AMD64 Family 23 Model 49 Stepping 0, AuthenticAMD
	myMMAProxyServer = No
	PROCESSOR_ARCHITECTURE = AMD64
	Path = C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;F:\ProgramFiles (x86)\Microsoft SQL Server\150\DTS\Binn\;C:\Program Files\Azure Data Studio\bin;F:\ProgramFiles\Microsoft SQL Server\150\DTS\Binn\;F:\ProgramFiles\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;F:\ProgramFiles (x86)\Microsoft SQL Server\150\Tools\Binn\;F:\ProgramFiles\Microsoft SQL Server\150\Tools\Binn\;C:\Program Files\MySQL\MySQL Shell 8.0\bin\;C:\Users\xxxxxxxxxxxx.NET\AppData\Local\Microsoft\WindowsApps;
	myWindowsServerPassiveMode = No
	PROCESSOR_REVISION = 3100
	TEMP = C:\Users\UBORJE~1.NET\AppData\Local\Temp\2
	USERPROFILE = C:\Users\xxxxxxxxxxxx.NET
	LOGONSERVER = \\NET6000
	myDisableADIntegration = No
	USERNAME = xxxxxxxxxxxx
	SystemRoot = C:\Windows
	myLocalDeployment = Yes
	USERDOMAIN_ROAMINGPROFILE = NET
	CommonProgramFiles = C:\Program Files\Common Files
	SystemDrive = C:
	myCleanUp = No
	ProgramData = C:\ProgramData
	myEnableDefender = No
	myOffboard = No
	COMPUTERNAME = NET4025
	myLogAnalytics = No
	myWorkspaceSwitch = No
	ALLUSERSPROFILE = C:\ProgramData
	CommonProgramW6432 = C:\Program Files\Common Files
	TMP = C:\Users\UBORJE~1.NET\AppData\Local\Temp\2
	SESSIONNAME = RDP-Tcp#24
	DriverData = C:\Windows\System32\Drivers\DriverData
	HOMEDRIVE = C:
	windir = C:\Windows
	mySourcePath = \\net.ucf.edu\sysvol\net.ucf.edu\MDEDeploy
	NUMBER_OF_PROCESSORS = 2
	OS = Windows_NT
	ProgramFiles = C:\Program Files
	ComSpec = C:\Windows\system32\cmd.exe
	HOMEPATH = \Users\xxxxxxxxxxxx.NET
	PATHEXT = .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
	ProgramFiles(x86) = C:\Program Files (x86)
	PSModulePath = C:\Program Files\WindowsPowerShell\Modules;C:\Windows\system32\WindowsPowerShell\v1.0\Modules;F:\ProgramFiles (x86)\Microsoft SQL Server\150\Tools\PowerShell\Modules\;C:\Program Files\Microsoft Monitoring Agent\Agent\PowerShell\
	myMMAProxyClient = No
	APPDATA = C:\Users\xxxxxxxxxxxx.NET\AppData\Roaming
	USERDOMAIN = NET
	PROCESSOR_LEVEL = 23
	LOCALAPPDATA = C:\Users\xxxxxxxxxxxx.NET\AppData\Local
	UATDATA = C:\Windows\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77
	CLIENTNAME = IKMPC75
	CommonProgramFiles(x86) = C:\Program Files (x86)\Common Files
	PUBLIC = C:\Users\Public
10:34:26 [INF][      Workbench]: Current version given by meta info is: 8.0.36
10:34:26 [INF][      Workbench]: Setting PATH to: C:\Windows\system32;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;F:\ProgramFiles (x86)\Microsoft SQL Server\150\DTS\Binn\;C:\Program Files\Azure Data Studio\bin;F:\ProgramFiles\Microsoft SQL Server\150\DTS\Binn\;F:\ProgramFiles\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;F:\ProgramFiles (x86)\Microsoft SQL Server\150\Tools\Binn\;F:\ProgramFiles\Microsoft SQL Server\150\Tools\Binn\;C:\Program Files\MySQL\MySQL Shell 8.0\bin\;C:\Users\xxxxxxxxxxxx.NET\AppData\Local\Microsoft\WindowsApps;
10:34:26 [INF][ mforms managed]: Initializing mforms wrapper
10:34:27 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE
	plugin path: F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE
	struct path: 
	module path: F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE/modules
	library path: F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE
	user data dir: C:\Users\xxxxxxxxxxxx.NET\AppData\Roaming\MySQL\Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
10:34:27 [INF][      WBContext]: WbContext::init
10:34:29 [INF][            WBA]: Looking for extension modules for WBA...
10:34:29 [INF][            WBA]: 0 extension modules found
10:34:30 [WRN][            grt]: Duplicate plugin name wb.tools.cmdlineClient	There is more than one plugin with the name wb.tools.cmdlineClient (in PyWbUtils and PyWbUtils).
10:34:30 [WRN][            grt]: C:\Users\xxxxxxxxxxxx.NET\AppData\Roaming\MySQL\Workbench\connections.xml:18: link '{ECFED0B1-264E-4EC5-8B7B-73CC77D67F98}' <object GrtObject> key=owner could not be resolved
10:34:30 [WRN][            grt]: Duplicate plugin name wb.tools.cmdlineClient	There is more than one plugin with the name wb.tools.cmdlineClient (in PyWbUtils and PyWbUtils).
10:34:30 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 8.0.36 CE build 3737333 (64 bit)
	Configuration Directory: C:\Users\xxxxxxxxxxxx.NET\AppData\Roaming\MySQL\Workbench
	Data Directory: F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE
	Cairo Version: 1.17.6
	OS: Microsoft Windows Server 2019 Standard
	CPU: 2x AMD EPYC 7452 32-Core Processor                , 16.0 GiB RAM
	Active video adapter Microsoft Hyper-V Video
	Installed video RAM: 0 MB
	Current video mode: 1024 x 768 x 4294967296 colors
	Used bit depth: 32
	Driver version: 10.0.17763.2145
	Installed display drivers: NULL
	Current user language: English (United States)

10:34:30 [INF][      Workbench]: UI is up
10:34:31 [INF][      Workbench]: Running the application
10:34:36 [ERR][       pymforms]: Unhandled exception in Python code: 
Traceback (most recent call last):
  File "F:\ProgramFiles\MySQL\MySQL Workbench 8.0 CE\modules\wb_utils_grt.py", line 725, in checkForUpdatesCallback
    if self.isAlive():
       ^^^^^^^^^^^^
AttributeError: 'CheckForUpdateThread' object has no attribute 'isAlive'
[8 Mar 12:20] MySQL Verification Team
Hello Ulf Borjesson,

Thank you for the bug report.
Imho this is duplicate of Bug #111096, please see Bug #111096.

Regards,
Ashwini Patil