Bug #113954 Workbench steals focus when opening a saved workspace
Submitted: 11 Feb 13:55 Modified: 17 Mar 11:30
Reporter: Dagh Bunnstad Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.33 buld 2947366 CE (64-bits) OS:Windows (Windows 11 Pro 22H2)
Assigned to: CPU Architecture:x86 (Intel Core i7-11700K @ 3.60GHz)
Tags: focus, workbench, workspace

[11 Feb 13:55] Dagh Bunnstad
Description:
Workbench continuously steals focus when opening a saved workspace.

If you have many tabs open in that workspace MySQL will keep stealing focus rendering the whole OS unusable and considering how innefficient the tab opening appears to be it's a real issue.

Since Workbench often (weekly to daily) randomly crashes with assertion errors (see e.g. Bug #113459), it makes this problem even worse.

How to repeat:
1. Open a new workspace/connection.

2. Open x number of tabs, where x is dependent on the performance of your computer, enough for it to take multiple seconds or even minutes to open a saved workspace.

3. Try to do anything else in your OS while Workbench is restoring the workspace.

4. You can't.

Suggested fix:
The fix is simple:
1. Don't steal focus.

And optionally:
2. Don't render opening every saved tab when opening a workspace, only after all tabs are open does one have to render them.
[11 Feb 13:57] Dagh Bunnstad
Fixed synopsis
[12 Feb 12:38] MySQL Verification Team
Hello Dagh Bunnstad,

Thank you for the bug report.
I tried to reproduce your issue on windows 11 with workbench 8.0.36 but I am not seeing any issues at my end.

Regards,
Ashwini Patil
[17 Mar 11:30] Dagh Bunnstad
I supplied a demonstration video file, has anyone looked at it?