Bug #11371 Problem with underscores in table names
Submitted: 16 Jun 2005 8:38 Modified: 6 Jul 2005 4:13
Reporter: Nicolai Hoge Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S2 (Serious)
Version:1.0.7 OS:Microsoft Windows (win2000)
Assigned to: CPU Architecture:Any

[16 Jun 2005 8:38] Nicolai Hoge
Description:
When trying to migrate a database from MS SQL Server with 4 tables who all have names starting with the same words, but with different suffixes after underscores:

A
A_B
A_C
A_C_A

The Toolkit ignores one of them. (A_C) It doesn not create a table on the target machine, and does not bulk transfer data.

If I later try to migrate only the one table, by ignoring the others it is impossible.
If I try to ignore the A_C table, it disappears from the list. If I try to unignore the A table, both A and A_C appears in the migrate list.

How to repeat:
Create an MS SQL server database with the following four tables:

service
service_configuration
service_paramater
service_parameter_value

Try to migrate and transfer data to a MySql server.

Suggested fix:
Solve problem with underscores /  table names that have identical start.
[16 Jun 2005 8:42] Nicolai Hoge
There was a typo in the how to repeat section.
The correct name for the third table was service_parameter
[6 Jul 2005 4:13] Jorge del Conde
I was unable to reproduce this bug using the latest version of Migration Toolkit.
[6 Jul 2005 4:13] Jorge del Conde
mysql> show tables;
+--------------------------+
| Tables_in_db1            |
+--------------------------+
| service                  |
| service_configuration    |
| service_parameters       |
| service_parameters_value |
+--------------------------+
4 rows in set (0.00 sec)

mysql>
[6 Jul 2005 6:36] Nicolai Hoge
I am sorry . I have now realized that the migration toolkit did not ignore them after all. There was a problem with the primary key in the table.

So there are really two new issues:

1. The migration toolkit seems to always take the first column of the source table
to be the primary key, even though another column or columns have been defined
as the primary key.

2. It took me a week to realize that something had gone wrong when creating the
schema on MySql. I had to copy the whole log into a text editor and search for "error". A flag in the GUI, or a searchable log would have been nice.