Bug #11364 ndb_mgmd cored on cluster shutdown
Submitted: 15 Jun 2005 22:41 Modified: 7 Jul 2005 15:08
Reporter: Jonathan Miller Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S2 (Serious)
Version:5.1.0-wl2325-wl1354-new OS:Linux (Linux)
Assigned to: Assigned Account CPU Architecture:Any

[15 Jun 2005 22:41] Jonathan Miller
Description:
This happed during a graceful Cluster shutdown. I had been doing slave cluster failure test, but the whole cluster was up and running when I issued the shutdown command. Steps and core location below.

How to repeat:
1) setup the cluster
2) restore the dump from master cluster
3) start the slave
4) crashed the cluster data nodes. (kill -9 on ndbd processes) 
5) restarted the cluster
6) restarted the slave replication, but the sql thread aborts with funny error message.
7) reset the slave
8) changed the epoch back to original number
9) reset host bin location
10) tried to get slave to process again. But still keep getting the same error message.
11) save off all files (var and run directories)
12) login into ndb_mgmd and issue shutdown
13) Found core.
[7 Jul 2005 15:08] Stewart Smith
Looks like a duplicate filing of:
http://bugs.mysql.com/bug.php?id=11516