Bug #113636 Crash when create a new model or open any saved model
Submitted: 14 Jan 10:24 Modified: 16 Jan 13:00
Reporter: Eric CS Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.34 OS:MacOS (unknown)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[14 Jan 10:24] Eric CS
Description:
----[For better reports, please attach the log file after submitting. You can find it in /Users/eric/Library/Application Support/MySQL/Workbench/log/wb.log]

When i open Mysql Workbench, i click in menu "File - New Model". 
The application close it self. 
This issue started after update the Mac Os to the latest version. 

/Users/eric/Library/Application Support/MySQL/Workbench/log/wb.log]
07:23:22 [INF][      Workbench]: Starting up Workbench
07:23:22 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /Applications/MySQLWorkbench.app/Contents/Resources
	plugin path: /Applications/MySQLWorkbench.app/Contents/PlugIns
	struct path: /Applications/MySQLWorkbench.app/Contents/Resources/grt
	module path: /Applications/MySQLWorkbench.app/Contents/PlugIns:/Applications/MySQLWorkbench.app/Contents/Resources/plugins
	library path: /Applications/MySQLWorkbench.app/Contents/Resources/libraries
	user data dir: /Users/eric/Library/Application Support/MySQL/Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
07:23:22 [INF][      WBContext]: WbContext::init
07:23:23 [INF][            WBA]: Looking for extension modules for WBA...
07:23:23 [INF][            WBA]: 0 extension modules found
07:23:23 [WRN][            grt]: Duplicate plugin name wb.tools.cmdlineClient	There is more than one plugin with the name wb.tools.cmdlineClient (in PyWbUtils and PyWbUtils).
07:23:23 [WRN][            grt]: /Users/eric/Library/Application Support/MySQL/Workbench/connections.xml:17: link '822E862A-7DFB-4BBB-BD6C-ECB338E985CC' <object GrtObject> key=owner could not be resolved
07:23:23 [WRN][            grt]: Duplicate plugin name wb.tools.cmdlineClient	There is more than one plugin with the name wb.tools.cmdlineClient (in PyWbUtils and PyWbUtils).
07:23:23 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for macOS version 8.0.34 CE build 3263449 (64 bit)
	Configuration Directory: /Users/eric/Library/Application Support/MySQL/Workbench
	Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
	Cairo Version: 1.17.6
	OS: unknown
	CPU: 8x Apple M1 - 8.00GiB RAM
No video adapter info available

07:23:23 [INF][   ModelContext]: Found model auto-save /Users/eric/Library/Application Support/MySQL/Workbench/newmodel.mwbd, but it is empty. Deleting it...
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_sakila_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_manage_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_folder@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_network_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_plus_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_user_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_plus_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_doc_sql@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_number_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_close@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_open_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_more_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_sakila_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_manage_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_folder@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_network_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_plus_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_user_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_plus_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_doc_sql@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_number_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_close@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_open_dark@2x.png
07:23:24 [WRN][         mforms]: Resource file not found: wb_tile_more_dark@2x.png
07:23:24 [WRN][       WBModule]: OS detection failed, skipping OS support check. OS string: 'unknown'
07:23:26 [WRN][         mforms]: Resource file not found: snippet_mwb@2x.png

How to repeat:
Just try make the same step again (create new model).
[15 Jan 19:59] Denise Geller
Related to Bug #112440?
[16 Jan 13:00] MySQL Verification Team
Hello Eric,

Thank you for the bug report.
Imho this is duplicate of Bug #112440, please see Bug #112440.

Regards,
Ashwini Patil