Bug #112756 MySQL Workbench crashes in macOS Sonoma.
Submitted: 17 Oct 2023 23:52 Modified: 18 Oct 2023 5:53
Reporter: Lucas Cavalcante Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.34 OS:MacOS (Sonoma)
Assigned to: CPU Architecture:Any (ARM and x86/64 thru Rosetta.)
Tags: closes., crash, crashing, macos, macOS Sonoma, model, sonoma, workbench

[17 Oct 2023 23:52] Lucas Cavalcante
The software completely crashes in an attempt to create or open a model (diagram).

I'm using a MacBook Pro with Apple Silicon (M2) and 8GB of RAM. Tried reboot, erasing the software completely and downloading a bunch of distinct versions of the software.
All results in the same problem.

Versions tried:
08.0.22 (X86_64)
08.0.33 (X86_64)
08.0.33 (ARM)
08.0.34 (X86_64)
08.0.34 (ARM)

Currently the latest version available is 08.0.34 (ARM and X86/64).

How to repeat:
Download and install the software (MySQL Workbench Community 8.0.34);
Open the software;
Click in File > New Model.
The software will crash.

It does not need to be a new model. You can also try to open an existing model and it will crash.

Suggested fix:
I have no Idea what to suggest as a fix. Maybe pray if you believe so... I prefer counting with the devs!
[18 Oct 2023 0:02] Lucas Cavalcante
video showing the bug happening

Attachment: CRASHING ON SONOMA-1.mov (video/quicktime, text), 44.66 MiB.

[18 Oct 2023 5:53] MySQL Verification Team
Hello Lucas,

Thank you for the bug report.
Imho this is duplicate of Bug #112440, please see Bug #112440.

Ashwini Patil
[18 Oct 2023 10:32] Alison Alain de Oliveira
Error message arm M1

Attachment: error_message_M1.rtf (text/rtf), 82.18 KiB.

[18 Oct 2023 10:35] Alison Alain de Oliveira
Several MAC`s here where I work present unexpected closing of MySQLWorkkbench, both for ARM and Intel.
[12 Jan 9:29] Bart De Baere
I'm having the same issue on a Macbook Pro M3 with Sonoma 14.2.1
I created a new diagram from the database (347 tables).
When I want to open this schema or create a new diagram, the application crashes.
Deleting the diagram doesn't work either.