Bug #11260 Connection failure - Unknown system variable 'sql_mode' (code 1193)
Submitted: 11 Jun 2005 12:15 Modified: 15 Jun 2005 5:48
Reporter: William Birkett Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S1 (Critical)
Version:1.0.21 OS:Mac OS X (Mac OS X 10.3.9)
Assigned to: CPU Architecture:Any

[11 Jun 2005 12:15] William Birkett
Description:
The Administrator client will not connect to a local server. It displays a dialog with the message "Connection Error - Could not connect to MySQL instance at localhost. Error: Unknown system variable 'sql_mode' (code 1193)" . The server version is 4.0.24-standard. The system variable 'sql_mode' does exist for this server, and has a value of 0.

How to repeat:
Install MySQL Administrator on Mac OS X and log-in to a local server.
[11 Jun 2005 12:16] William Birkett
pdf of the connection error dialog.

Attachment: Connection_Error.pdf (application/x-msdownload, text), 28.52 KiB.

[11 Jun 2005 12:17] William Birkett
pdf of 'show variables' output.

Attachment: Show_Variables.pdf (application/x-msdownload, text), 21.78 KiB.

[11 Jun 2005 15:51] Olav Brinkmann
I get the same error when trying to connect to a remote server. I also get this error when using the MySQL Query Browser 1.1.0-alpha.
[13 Jun 2005 9:02] Reinhard Blumauer
Unknown system variable 'sql_mode' (code 1193)
I get the same error on 3 different mySQL servers. So I can not test or try at all. Im using OSX 10.3.9 Server on various mySQL 4.0x
[15 Jun 2005 5:48] Alfredo Kojima
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html