Bug #112578 MacOs Sonoma crash when opening model
Submitted: 30 Sep 7:29 Modified: 3 Oct 8:54
Reporter: Chris Mills Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version:Have tried all versions back to 8.0 OS:MacOS (Sonoma 14.0)
Assigned to: CPU Architecture:ARM (M1)

[30 Sep 7:29] Chris Mills
Unable to open models in Workbench or to open models via finder in workbench.
System immediately crashes

How to repeat:
Open a model (.MWB)

Suggested fix:
unknown fix. Unable to find any workarounds.
Same .MWB file opens perfectly when running MacOS Ventura
[30 Sep 7:30] Chris Mills
MacOS Crash report

Attachment: workbench crash log.rtf (text/rtf), 77.12 KiB.

[1 Oct 21:17] On Tsang
Similar experience on my M2 Mac Mini running Mac OS X Sonoma.

Creating a new model crashes the application. Tried removing the application and re-installing but the same crash happens.
[1 Oct 21:26] On Tsang

Attachment: CrashReport.rtf (text/rtf), 125.92 KiB.

[2 Oct 21:24] Gerson Felipe Schwinn
I have the same problem here, I can't open any workbench files anymore after updating to macOS 14
[3 Oct 8:54] MySQL Verification Team
Hello Chris,

Thank you for the bug report.
Imho this is duplicate of Bug #112440, please see Bug #112440.

Ashwini Patil