Bug #11253 Test suite hangs if mysqld process is already running
Submitted: 10 Jun 2005 19:16 Modified: 3 Aug 2006 15:31
Reporter: Jonathan Miller Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Server Severity:S2 (Serious)
Version:5.0 OS:Any (All)
Assigned to: Magnus Blåudd CPU Architecture:Any

[10 Jun 2005 19:16] Jonathan Miller
mysql-test-run will loop waiting for master.pid1 if --with-ndbcluster

If I run tests with ndbcluster (just by calling ./mysql-test-run) the script will loop forever (400 seconds) waiting for master.pid1.

If I skip the cluster, the tests run perfectly.
I experience it both in 4.1 and 5.0 and spend half an hour trying to debug already, but with no luck.
I can't tell you how to repeat it (just compile the tree and run the test), but I can provide you with a login to my box (thanks to Kent who taught me how).

Konstantin Osipov, Software Developer
MySQL AB, www.mysql.com

I ran into this a week or two ago, and it seems that it was a mysqld process that was sticking around. Have you done a ps -e before running the test to make sure no other process is running?

Jonathan Miller
Austin, Texas USA
QA Developer

MySQL AB www.mysql.com

Why should I? I always have mysqld running, why must it interfere with the test suite?
Team: I've just verified, Jonathan is correct. 
So it's a bug, please fix.

Jonathan: thank you for helping me out.

Konstantin Osipov, Software Developer
MySQL AB, www.mysql.com

How to repeat:
Follow instruction above.
[3 Aug 2006 15:31] Magnus Blåudd
Bug has been in Verified for more than 400 days and this haven't been seen in a while.