Bug #11200 show instance options returns garbage instead of log options
Submitted: 9 Jun 2005 12:07 Modified: 13 Jul 2005 19:24
Reporter: Petr Chardin Email Updates:
Status: Closed Impact on me:
None 
Category:Instance Manager Severity:S3 (Non-critical)
Version:5.0.7 OS:Linux (Suse Linux)
Assigned to: Petr Chardin CPU Architecture:Any

[9 Jun 2005 12:07] Petr Chardin
Description:
Instance manager doesn't display log options correctly. This bug is non-deterministic.

Sample output from mysql client:

mysql> show instance options mysqld;
+------------------+---------------------------------------------------+
| option_name      | value                                             |
+------------------+---------------------------------------------------+
| instance_name    | mysqld                                            |
| mysqld-path      | /usr/local/mysql/libexec/mysqld                   |
| nonguarded       |                                                   |
| socket           | /home/cps/var/mysql/mysql.sock                    |
| port             | 3307                                              |
| language         | /home/cps/mysql/trees/mysql-5.0/sql/share/english |
| server_id        | 1                                                 |
| basedir          | /home/cps/mysql/trees/mysql-5.0                   |
| datadir          | /home/cps/var/mysql                               |
| skip-stack-trace |                                                   |
| core-file        |                                                   |
| skip-bdb         |                                                   |
| log-bin          |                                                   |
| log              | �/p/�/x/|/�/�/log-slow-queries      |
| log-slow-queries |                                                   |
| log-error        |                                                   |
| pid-file         | mysqld-owlet.pid                                  |
+------------------+---------------------------------------------------+

How to repeat:
issue "show instance options <instance_name>" for the instance wich has log enabled. Several times as bug doesn't happen all the time.

Suggested fix:
Looks like wrong work with the memory, which is quite likely as this was recently changed.
[9 Jun 2005 19:21] Jorge del Conde
Verified w/5.0.7 from bk
[14 Jun 2005 13:15] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25977
[14 Jun 2005 23:21] Petr Chardin
The problem is not specific to the log files. I affects any option, for which the value is not set. (E.g. --log, --core-file e.t.c).
[13 Jul 2005 19:24] Paul Dubois
Noted in 5.0.8 changelog.