Bug #11176 Can't edit stored procedures containing wildcards
Submitted: 8 Jun 2005 16:25 Modified: 8 Jun 2005 17:13
Reporter: Robin Bailes Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.9 OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[8 Jun 2005 16:25] Robin Bailes
Description:
I created the following stored procedure that included a "LIKE '%F'" clause.  
When I try to edit it from wuery browser I get an error "No argument for format '%F'"

How to repeat:
-- Create the test table
DROP TABLE IF EXISTS `test`.`testtable`;
CREATE TABLE `testtable` (
  `Col1` varchar(20) NOT NULL,
  PRIMARY KEY  (`Col1`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1;

-- Create the stored procedure
DELIMITER $$

DROP PROCEDURE IF EXISTS `test`.`prcTest`$$
CREATE PROCEDURE `test`.`prcTest`()
begin
SELECT *
FROM testtable
WHERE Col1 LIKE '%F';
end$$

DELIMITER ;

-- Edit the procedure
Right click the procedure and select edit.  No edit panel is populated and a message in the status bar at the bottom says No arguement for format "%F"
[8 Jun 2005 17:13] Jorge del Conde
I was unable to reproduce this behaviour because of bug #11180
[10 Jun 2005 15:44] Robin Bailes
I get the same problem when I include this FORMAT statement:
DATE_FORMAT(GameDate, '%a %d, %b, %Y')

A work around is to copy the proc to the clipboard and paste it into the editor.
[19 Jun 2005 19:45] Robin Bailes
Upgraded to version 1.1.10.  Problem still exists.