Bug #11170 MyODBC fetching whole table if query is empty
Submitted: 8 Jun 2005 12:36 Modified: 28 May 2013 10:50
Reporter: [ name withheld ] Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.11-2 OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any

[8 Jun 2005 12:36] [ name withheld ]
Description:
A Visual Foxpro application generates a remote view with flag "nodata" to get table structures. This causes MyODBC to issue an empty query. Because it cannot fetch information, it issues a "select * from 'table'" for every table that is queried in the SQL query.

Unfortunately, this causes huge amount of traffic and blocking of server.

Tested with MyODBC 3.51.11-2 as well as 3.51.06 on WinXP, windows and linux MySQL server, versions 4.1.12 and 5.0.6-beta.

How to repeat:
Create a remote view in Visual Foxpro (maybe in VB, too) with option nodata and do a requery() with where-clause afterwards.
[13 Jun 2005 5:50] Vasily Kishkin
I was not able to reproduce that bug on VB. Could you please correct my test case or attach your one ? My test case is attached.
[13 Jun 2005 5:51] Vasily Kishkin
Test case

Attachment: 11170.zip (application/x-zip-compressed, text), 3.45 KiB.

[13 Jul 2005 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 May 2013 10:50] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.