Bug #11082 Make original select_statement for a view accessible
Submitted: 3 Jun 2005 19:23 Modified: 6 Oct 2008 15:09
Reporter: Jim Winstead Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Views Severity:S4 (Feature request)
Version:5.0 OS:Any
Assigned to: CPU Architecture:Any
Triage: D5 (Feature request)

[3 Jun 2005 19:23] Jim Winstead
Description:
SHOW CREATE VIEW and INFORMATION_SCHEMA.VIEWS.VIEW_DEFINITION show the          
normalized version of the select_statement used to create the view. For some use cases, it 
is desirable to get the original select_statement rather than the normalized
version.

See the thread at http://lists.mysql.com/internals/25437 for more discussion.

How to repeat:
CREATE VIEW v1 AS SELECT /* comment */ a FROM t1;
[12 Mar 2006 1:43] Markus Popp
The request is about 9 months old now - I think that this is quite an important issue and I am sure that many MySQL users are waiting to get access to their original view definition.
[11 Dec 2006 14:05] Martijn Tonies
>"The request is about 9 months old now "

Apparently, no-one of the MySQL developers thinks this makes any sense?

Please, get this fixed!

--
Martijn Tonies
[6 Nov 2007 12:35] Pavel Jurzykowski
See also Bug #19602 and Bug #5159
[6 Oct 2008 15:09] Valeriy Kravchuk
This is a duplicate of bug #5159.