Bug #110754 connector/net fails with visual studio 2019
Submitted: 20 Apr 2023 23:42 Modified: 22 Apr 2023 20:19
Reporter: David Gilman Email Updates:
Status: Can't repeat Impact on me:
Category:Connector / NET Severity:S2 (Serious)
Version:8.0.33 OS:Windows
Assigned to: CPU Architecture:Any

[20 Apr 2023 23:42] David Gilman
After upgrade from 8.0.32 to 8.0.33 Connector/Net no longer works using Visual Studio 2019. I noted that the Assemblies subdirectory is no longer installed. I get this error on a myConnection.BeginTransaction() call with Framework 4.8, and on myConnection.Open() with Net 5.0.

System.IO.FileNotFoundException: 'Could not load file or assembly 'System.Threading.Tasks.Extensions, Version=, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The system cannot find the file specified.'

How to repeat:
Visual Studio 2019 > New project > C# Console App (either Framework or Net Core) > 

MySqlConnection conn = new MySqlConnection(myConnexParms);
conn.Open(); // NET 5.0 fails here.
MySqlTransaciton trans = conn.BeginTransaction(); // Framework 4.8 fails here.
[21 Apr 2023 0:13] David Gilman
Additional info:

This is MySQL 8.0.33 Community Edition.
Windows 10 Pro 22H2 19045.2846
Visual Studio Community 2019 16.11.26

Also, downgrading to Connector/Net 8.0.32 works with Framework 4.8, but not NET Core 5.0.
[21 Apr 2023 12:37] MySQL Verification Team
Hello David,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with Connector/NET 8.0.33 and Visual Studio 2019 but I am not seeing any issues at my end. If you can provide more information, feel free to add it to this bug. Thanks.

Ashwini Patil
[21 Apr 2023 19:42] David Gilman
I tried it with Framework 4.7.2 and 4.8.1 with the same results as 4.8. 

Here are the usings:

using System;
using MySql.Data.MySqlClient;
using System.Data;

This is all that is needed with Connector/NET 8.0.32, with the assembly found in Program Files (86)\MySQL\Connector NET 8.0\Assemblies\v4.8.
[22 Apr 2023 20:19] David Gilman
I solved this by adding System.Threading.Tasks.Extensions v4.5.4 via NuGet. I didn't see any indication of this in the on-line documentation for installing on windows, nor have I ever needed to do this with previous versions. Perhaps you should update your documentation.