Bug #110670 I click on the + under database connections and nothing happens
Submitted: 12 Apr 19:20 Modified: 11 May 22:31
Reporter: Sean O'Connor Email Updates:
Status: Can't repeat Impact on me:
Category:Shell VSCode Extension Severity:S1 (Critical)
Version:1.9.1 OS:Windows
Assigned to: CPU Architecture:Any

[12 Apr 19:20] Sean O'Connor
After 7 years of a bug in MYSQL Workbench causing our team frustration I was excited to see this new plug-in.  I loaded it and when I hit the + on the database connections..  nothing happens..  It seems very self explanatory, hit the plus to create a connection..   But it does nothing.  

Version: 1.77.3 (user setup)
Commit: 704ed70d4fd1c6bd6342c436f1ede30d1cff4710
Date: 2023-04-12T09:16:02.548Z
Electron: 19.1.11
Chromium: 102.0.5005.196
Node.js: 16.14.2
OS: Windows_NT x64 10.0.19044
Sandboxed: Yes

Error log:
12:17:51.800542 INFO: Starting MySQL Shell GUI web server...

12:17:51.801541 INFO: 	Checking web server certificate...

12:17:51.990659 INFO: 	Certificate is installed.

12:17:51.997691 ERROR: Log message could not be inserted into db. near "Connor": syntax error

Could it be because my name has an apostrophe in it and somehow that is preventing me from creating a database connection?

How to repeat:
Click on the database connection + and nothing happens.
[12 Apr 19:21] Sean O'Connor
Updating severity
[13 Apr 12:25] MySQL Verification Team
Hello Sean O'Connor,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with Shell VSCode Extension 1.9.1 but I am not seeing any issues at my end. Please see Bug #106843 and check the steps suggested by dev. Thanks.

Ashwini Patil
[13 Apr 12:26] MySQL Verification Team
Shell VSCode Extension 1.9.1 test results

Attachment: 110670_test_results.PNG (image/png, text), 125.57 KiB.

[8 May 18:01] Sean O'Connor
How could you reproduce it if you didn't setup the situation to be the same as mine?  My last name is O'Connor and has an apostrophe.  Did you try it with a user who's winodws name has an apostrophe in it?  It won't reproduce unless you have a user who's name in windows has an apostrophe.  How can I get past this?
[8 May 18:05] Sean O'Connor
Please see the last error in my submission:
12:17:51.997691 ERROR: Log message could not be inserted into db. near "Connor": syntax error.

This is right after the apostrophe in my name.  You must have some sort of sql without parameters in your code, otherwise this would not occur.

Can you please try it for a user who's windows name has an apostrophe.  I tried to remove it however It's all integrated with my enterprise and my name is too ingrained in the windows system.
[11 May 22:31] Sean O'Connor
Are you still monitoring this bug or do I need to submit a new one?