Bug #11051 schemata browser - Copy SQL to Clipboard = No argument for format '%R'
Submitted: 2 Jun 2005 20:20 Modified: 3 Jun 2005 14:57
Reporter: Oliver Peters Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.9 OS:Microsoft Windows (Windows2000)
Assigned to: CPU Architecture:Any

[2 Jun 2005 20:20] Oliver Peters
Description:
table name: ehsicht_1

show create table ehsicht_1;

works fine
(
CREATE TABLE `ehsicht_1` (
  `KDNR` mediumint(5) unsigned NOT NULL default '0',
  `NAME` char(23) NOT NULL default '',
  `G_ART` tinyint(1) unsigned NOT NULL default '0',
  `WGOG` tinyint(2) unsigned NOT NULL default '0',
  `EW` tinyint(1) unsigned NOT NULL default '0',
  `alle_Objekte_AnzObj` smallint(5) unsigned NOT NULL default '0',
  `alle_Objekte_TB` smallint(5) unsigned NOT NULL default '0',
  `alle_Objekte_ØTB` double unsigned NOT NULL default '0',
  `alle_Objekte_RM` smallint(5) unsigned NOT NULL default '0',
  `alle_Objekte_%RM` double unsigned NOT NULL default '0',
  `alle_Objekte_VK` smallint(5) unsigned NOT NULL default '0',
  `alle_Objekte_ØVK` double unsigned NOT NULL default '0',
  `ohne_Fr_AnzObj` smallint(5) unsigned NOT NULL default '0',
  `ohne_Fr_TB` smallint(5) unsigned NOT NULL default '0',
  `ohne_Fr_ØTB` double unsigned NOT NULL default '0',
  `ohne_Fr_RM` smallint(5) unsigned NOT NULL default '0',
  `ohne_Fr_%RM` double unsigned NOT NULL default '0',
  `ohne_Fr_VK` smallint(5) unsigned NOT NULL default '0',
  `ohne_Fr_ØVK` double unsigned NOT NULL default '0',
  `mit_Fr_AnzObj` smallint(5) unsigned NOT NULL default '0',
  `mit_Fr_TB` smallint(5) unsigned NOT NULL default '0',
  `mit_Fr_ØTB` double unsigned NOT NULL default '0',
  `mit_Fr_RM` smallint(5) unsigned NOT NULL default '0',
  `mit_Fr_%RM` double unsigned NOT NULL default '0',
  `mit_Fr_Expl` smallint(5) unsigned NOT NULL default '0',
  `mit_Fr_VK` smallint(5) unsigned NOT NULL default '0',
  `mit_Fr_ØVK` double unsigned NOT NULL default '0',
  `Fr_sk_AnzObj` smallint(5) unsigned NOT NULL default '0',
  `Fr_sk_TB` smallint(5) unsigned NOT NULL default '0',
  `Fr_sk_ØTB` double unsigned NOT NULL default '0',
  `Fr_sk_RM` smallint(5) unsigned NOT NULL default '0',
  `Fr_sk_%RM` double unsigned NOT NULL default '0',
  `Fr_sk_Expl` smallint(5) unsigned NOT NULL default '0',
  `Fr_sk_VK` smallint(5) unsigned NOT NULL default '0',
  `Fr_sk_ØVK` double unsigned NOT NULL default '0',
  `Fr_k_AnzObj` smallint(5) unsigned NOT NULL default '0',
  `Fr_k_TB` smallint(5) unsigned NOT NULL default '0',
  `Fr_k_ØTB` double unsigned NOT NULL default '0',
  `Fr_k_RM` smallint(5) unsigned NOT NULL default '0',
  `Fr_k_%RM` double unsigned NOT NULL default '0',
  `Fr_k_Expl` smallint(5) unsigned NOT NULL default '0',
  `Fr_k_VK` smallint(5) unsigned NOT NULL default '0',
  `Fr_k_ØVK` double unsigned NOT NULL default '0',
  `Fr_avk_AnzObj` smallint(5) unsigned NOT NULL default '0',
  `Fr_avk_TB` smallint(5) unsigned NOT NULL default '0',
  `Fr_avk_ØTB` double unsigned NOT NULL default '0',
  `Fr_avk_RM` smallint(5) unsigned NOT NULL default '0',
  `Fr_avk_%RM` double unsigned NOT NULL default '0',
  `Fr_avk_Expl` smallint(5) unsigned NOT NULL default '0',
  `Fr_avk_VK` smallint(5) unsigned NOT NULL default '0',
  `Fr_avk_ØVK` double unsigned NOT NULL default '0',
  `Fr_vk_AnzObj` smallint(5) unsigned NOT NULL default '0',
  `Fr_vk_TB` smallint(5) unsigned NOT NULL default '0',
  `Fr_vk_ØTB` double unsigned NOT NULL default '0',
  `Fr_vk_RM` smallint(5) unsigned NOT NULL default '0',
  `Fr_vk_%RM` double unsigned NOT NULL default '0',
  `Fr_vk_Expl` smallint(5) unsigned NOT NULL default '0',
  `Fr_vk_VK` smallint(5) unsigned NOT NULL default '0',
  `Fr_vk_ØVK` double unsigned NOT NULL default '0',
  PRIMARY KEY  (`KDNR`,`G_ART`,`WGOG`,`EW`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1
)

How to repeat:
produce the table above (description) and try "Copy SQL to Clipboard" in the schemata browser (right click on the table schema)

BTW: the history doesn't show Ø but Ø

Suggested fix:
I really don't know - I'm just a heavy user ;-)
[2 Jun 2005 23:20] Jorge del Conde
Thanks for your bug report.
[2 Jun 2005 23:20] Jorge del Conde
bug screenshot

Attachment: Image1.png (image/x-png, text), 48.58 KiB.

[3 Jun 2005 14:57] Michael G. Zinner
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html