Bug #109999 "Format current block or script" doesn't seem to work
Submitted: 9 Feb 2023 8:05 Modified: 9 Feb 2023 15:43
Reporter: Daniël van Eeden (OCA) Email Updates:
Status: Verified Impact on me:
Category:Shell VSCode Extension Severity:S3 (Non-critical)
Version:v1.7.1 OS:Fedora
Assigned to: CPU Architecture:Any

[9 Feb 2023 8:05] Daniël van Eeden
While connected to MySQL 8.0.32 in a DB Notebook the "Format current block or script" button doesn't seem to work. The same is true for the SQL script interface.

How to repeat:
Try to get MySQL Shell for VS Code to format a query like this:

[9 Feb 2023 15:12] MySQL Verification Team
Hi Daniel,

Did this ever worked? Button does not work on Linux nor on Windows with extension v1.7.1 - verified as described.

Thank you for the report
[9 Feb 2023 15:43] Daniël van Eeden
I've tried an older v1.7 version and a v1.6 version and there formatting also doesn't seem to work.
[9 Feb 2023 15:44] MySQL Verification Team
Thanks for the confirmation. I doubt this feature is (was ever) supported so this will probably be turned from bug to feature request. In any case good that it is recorded. Thanks!