Bug #10983 gis-rtree failure
Submitted: 31 May 2005 13:21 Modified: 31 May 2005 23:45
Reporter: Khalid Shukri Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.1.12 OS:Linux (Linux)
Assigned to: CPU Architecture:Any

[31 May 2005 13:21] Khalid Shukri
make test fails  with the following message:
Aborting. gis-rtree failed in default mode
System: Debian sarge
Kernel: 2.4.18-686-smp
glibc 2.3.2.ds1-22

How to repeat:
./configure --prefix=/usr/local/stow/mysql --exec-prefix=/usr/local/stow/mysql --localstatedir=/var/lib/mysql --sysconfdir=/etc/mysql --with-mysqld-ldflags=-all-static --with-unix-socket-path=/var/run/mysqld/mysqld.sock --enable-assembler --enable-local-infile --enable-thread-safe-client --with-charset=latin1 --without-innodb --with-extra-charsets=none  --with-pthread CC="gcc-3.2" CFLAGS="-O3 -mcpu=pentium4 -march=pentium4 -mfpmath=sse -felide-constructors -fomit-frame-pointer -fno-exceptions -fno-rtti" CXX="g++-3.2" CXXFLAGS="-O3 -mcpu=pentium4 -march=pentium4 -mfpmath=sse -felide-constructors  -fomit-frame-pointer -fno-exceptions
make test
[31 May 2005 13:26] Khalid Shukri
Corrected Version
[31 May 2005 13:27] Khalid Shukri
Output of  'make test'

Attachment: test.log (application/octet-stream, text), 14.43 KiB.

[31 May 2005 23:45] MySQL Verification Team
I was unable to repeat this issue on Knoppix 3.7 (Debian based):

func_timestamp                 [ pass ]
gcc296                         [ pass ]
gis-rtree                      [ pass ]
gis                            [ pass ]
grant                          [ pass ]
grant2                         [ pass ]

tested on current BK source.
[1 Jun 2005 21:02] Khalid Shukri
I tried with gcc-3.3 and changed the compiler options in the configuration accordingly. This works.
gcc-3.2 still gives the same error. Maybe a bug in gcc? Anyway, my problem is solved, but I'll supply you any additional information you need about my system, if you're interested