Bug #109625 NOT ABLE TO CREATE UNIQUE WITH MORE THAN 16 COLUMNS
Submitted: 13 Jan 11:54 Modified: 13 Jan 14:07
Reporter: GANESA KUMAR Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version:8.0.28 OS:Windows
Assigned to: CPU Architecture:Any

[13 Jan 11:54] GANESA KUMAR
Description:
NOT ABLE TO CREATE UNIQUE WITH MORE THAN 16 COLUMNS.

My table is having 25 columns. I want to create UNIQUE WITH 20 columns.

But MYSQL Does not allow to create UNIQUE KEY for more than 16 columns.

Due to this i could not perform UPSERT function.

How to repeat:
Create table with more than 16 columns and create UNIQUE KEY for more than 16 columns

Suggested fix:
Postgres is allowing upto 32 columns
[13 Jan 13:54] MySQL Verification Team
Hi Mr. KUMAR,

Thank you for your bug report.

However, there are limits to the width of the indices, sizes of the fixed part of the attributes etc .....

This is all described in our Reference Manual.

Not a bug.
[13 Jan 14:07] GANESA KUMAR
Thanks for prompt reply.

Kindly share the alternate way to perform UPSERT function for this kind of case .

Otherwise table will have duplicate records.

Please help