Bug #108081 Error Parsing DDL - Missing Acute ` characters before and after table and column
Submitted: 5 Aug 14:02 Modified: 29 Sep 14:38
Reporter: Piotr Zeglinski Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.30 OS:Windows (Windows 10 Enterprise)
Assigned to: CPU Architecture:Any (X64)
Tags: #MySQL_Workbench #Acute #DDL_Error

[5 Aug 14:02] Piotr Zeglinski
Description:
After the last update of MySQL Workbench (to version 8.0.30) and MySQL Server (to version 8.0.30), we noticed that some views reflect DDL Errors.

These views differ from the others in that they have special characters such as ☹, ↓, ↔ or ↑. When trying to open a view that is infected, the following window appears: "Error Parsing DDL for` name_schema`.`name_view`. There was an error while parsing the DDL retrived from the server. Do you want to view the DDL or cancel processing it? ".

After clicking on View DDL, the code is shown which is correct until it comes to the first special character (mentioned earlier). After the given special character, MySQL Workbench no longer displays the Acute ` character in the code. As a result, MySQL Workbench is unable to identify the table and columns correctly - some of them have a space (empty character) and consist of two words.

How to repeat:
1. Open MySQL Workbench (8.0.30) on Windows.
2. Create a view that will consist of special characters such as: ☹, ↓, ↔ or ↑.
3. Create / use a table and a column that has a blank character in the name like `Products table`.` Sales column`.
4. Save the view and reopen
5. A message will pop up on the screen: "Error Parsing DDL for` name_schema`.`name_view`. There was an error while parsing the DDL retrived from the server. Do you want to view the DDL or cancel processing it?".

Suggested fix:
The latest version has problems with understanding special characters - of course, they are only text and it should not matter, but after their occurrence, MySQL does not display acute `characters, which does not allow the tool to correctly understand the code.
[7 Aug 19:28] Piotr Zeglinski
NOTE: According to our experience and testing, the problem described does not apply to MySQL Server but to MySQL Workbench which was introduced between 8.0.22 and 8.0.23 (everything works fine up to 8.0.22). In addition, MySQL Client, MySQL for Excel and phpMyAdmin tests were performed and everything works fine (again - the problem only affects MySQL Workbench).
[7 Aug 21:18] Piotr Zeglinski
DDL Error - Missing acute ` characters (graphical description of the problem)

Attachment: DDL Error - Acute.png (image/png, text), 149.21 KiB.

[8 Aug 12:11] MySQL Verification Team
Hello,

Thank you for the bug report.
Imho this is duplicate of Bug #105646, please see Bug #105646.

Regards,
Ashwini Patil
[9 Aug 10:21] Piotr Zeglinski
Hi MySQL Verification Team, 

If may I ask - when can we expect this bug to be fixed? This is very important to us as we are unable to modify the code when the DDL error occurs.

Is there a chance that in version 8.0.31 this bug will be fixed?

Best regards,
Piotr Zeglinski
[16 Aug 11:33] Kuba Kubowski
I have exactly the same problem with special characters and missing acutes. Do you have any solution for that?
[29 Sep 14:38] Piotr Zeglinski
Hi, do we have any update for this issue?