Bug #107968 MySQL crashes with InnoDB errors
Submitted: 26 Jul 2:36 Modified: 26 Jul 14:24
Reporter: Glen Loren Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version: OS:Debian
Assigned to: CPU Architecture:x86

[26 Jul 2:36] Glen Loren
Description:
I'm running MySQL on a Debian distro. Recently it crashed and won't start. Here is the log file:

220725 18:13:03 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
220725 18:13:03 [Note] Plugin 'FEDERATED' is disabled.
220725 18:13:03 InnoDB: The InnoDB memory heap is disabled
220725 18:13:03 InnoDB: Mutexes and rw_locks use GCC atomic builtins
220725 18:13:03 InnoDB: Compressed tables use zlib 1.2.8
220725 18:13:03 InnoDB: Using Linux native AIO
220725 18:13:03 InnoDB: Initializing buffer pool, size = 128.0M
220725 18:13:03 InnoDB: Completed initialization of buffer pool
220725 18:13:03 InnoDB: highest supported file format is Barracuda.
InnoDB: Error: tried to read 65536 bytes at offset 0 125952.
InnoDB: Was only able to read 1024.
InnoDB: Fatal error: cannot read from file. OS error number 17.
220725 18:13:24  InnoDB: Assertion failure in thread 140443736074048 in file os0file.c line 2549
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
23:13:24 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

key_buffer_size=16777216
read_buffer_size=131072
max_used_connections=0
max_threads=151
thread_count=0
connection_count=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 346701 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x30000
/usr/sbin/mysqld(my_print_stacktrace+0x33)[0x55a95e0820f3]
/usr/sbin/mysqld(handle_fatal_signal+0x3e4)[0x55a95df6db14]
/lib/x86_64-linux-gnu/libpthread.so.0(+0xf890)[0x7fbb9abe3890]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37)[0x7fbb995d9067]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x148)[0x7fbb995da448]
/usr/sbin/mysqld(+0x642503)[0x55a95e1db503]
/usr/sbin/mysqld(+0x607543)[0x55a95e1a0543]
/usr/sbin/mysqld(+0x63403d)[0x55a95e1cd03d]
/usr/sbin/mysqld(+0x639bc9)[0x55a95e1d2bc9]
/usr/sbin/mysqld(+0x58ec98)[0x55a95e127c98]
/usr/sbin/mysqld(+0x55b435)[0x55a95e0f4435]
/usr/sbin/mysqld(_Z24ha_initialize_handlertonP13st_plugin_int+0x3f)[0x55a95df6fd0f]
/usr/sbin/mysqld(+0x2f7731)[0x55a95de90731]
/usr/sbin/mysqld(_Z11plugin_initPiPPci+0x903)[0x55a95de94bd3]
/usr/sbin/mysqld(+0x27d898)[0x55a95de16898]
/usr/sbin/mysqld(_Z11mysqld_mainiPPc+0x45b)[0x55a95de1b85b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7fbb995c5b45]
/usr/sbin/mysqld(+0x279258)[0x55a95de12258]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
unknown
[26 Jul 14:24] MySQL Verification Team
Hi Mr. Loren,

Thank you for your bug report.

However, this seems like an error in the I/O, which can be either a hardware error or OS error.

If you think otherwise, then please do send us a fully repeatable test case, so that we can reproduce the assertion.

Read about it further on.

Not enough information was provided for us to be able to handle this bug. Please re-read the instructions at http://bugs.mysql.com/how-to-report.php 

If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.  

Thank you for your interest in MySQL.