Bug #107439 MS Access with a linked table to a MySql/MariaDB instance cannot update row
Submitted: 31 May 20:43 Modified: 17 Jun 6:36
Reporter: Gregg Wonderly Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version: OS:Windows (Windows 10, Access using 8.0.29 connector)
Assigned to: CPU Architecture:x86 (64-bit connector)
Tags: 64-bit, access, connector, v8.0.29

[31 May 20:43] Gregg Wonderly
Description:
[MYSQL][ODBC 8.0(a) Driver][mysqld-5.5.5-10.4.21-MariaDB-log]Date overflow (#0) error received in Access when trying to access "linked" table on a mysql/MariaDB instance.

schema:
+-----------+--------------+------+-----+---------+----------------+
| Field     | Type         | Null | Key | Default | Extra          |
+-----------+--------------+------+-----+---------+----------------+
| idx       | bigint(20)   | NO   | PRI | NULL    | auto_increment |
| siteid    | bigint(20)   | NO   | MUL | NULL    |                |
| startdate | datetime     | NO   |     | NULL    |                |
| enddate   | datetime     | NO   |     | NULL    |                |
| skid      | int(11)      | YES  |     | NULL    |                |
| active    | tinyint(1)   | YES  |     | NULL    |                |
| comments  | varchar(512) | YES  |     | NULL    |                |
+-----------+--------------+------+-----+---------+----------------+

How to repeat:
In Access under Windows 10 using Office 365, version 2205 create a linked table reference to a mysql instance with the above defined table schema.   Insert several rows with times on the dates for some start date and endDate rows.  Then try to edit the dates and save.  The above error occurs which seems to indicate that there is a problem with how the timestamps are managed.  If both dates have no timestamp on them, only dates, those rows can be updated.
[1 Jun 7:53] Zoltán Szalai
Please, try to use the 8.0.29 driver with "NO_DATE_OVERFLOW=1" connection option.

See also: https://bugs.mysql.com/bug.php?id=107235
[17 Jun 6:36] MySQL Verification Team
Hello,

Thank you for the bug report.
Imho this is duplicate of Bug #107235, please see Bug #107235.

Regards,
Ashwini Patil